Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 105981 - REF: Refactoring in Palette
REF: Refactoring in Palette
Status: VERIFIED DUPLICATE of bug 106831
Product: guibuilder
Classification: Unclassified
Component: Code
6.x
All Linux
: P3 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-07 09:43 UTC by Jiri Vagner
Modified: 2007-08-20 12:30 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Vagner 2007-06-07 09:43:16 UTC
I add TestVisualBean component into Palette. After renaming "TestVisualBean" to
"MyTestVisualBean" I'm able to add component from palette, but it will create
invalid code, it will add old "TestVisualBean testVisualBean1".

Steps to reproduce:
 - Create frame
 - Add TestVisualBean.java into project and compile it
 - Add this class into Bean palette
 - Rename TestVisualBean to MyTestVisualBean and compile it
 - Add TestVisualBean from Palette
 - Try to compile form file
Comment 1 Tomas Pavek 2007-07-12 13:21:12 UTC
One of the refactoring scenarios that won't be supported for 6.0.

*** This issue has been marked as a duplicate of 106831 ***
Comment 2 Jiri Vagner 2007-08-20 12:30:40 UTC
Ok, verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo