Bug 105961 - unresponsive IDE after startup
unresponsive IDE after startup
Status: RESOLVED INVALID
Product: javascript
Classification: Unclassified
Component: Editor
6.x
All Linux
: P1 (vote)
: 6.x
Assigned To: issues@ide
issues@javascript
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-07 04:03 UTC by gnufied
Modified: 2009-02-27 14:26 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
jstack dump of ide during unresponsive period (10.39 KB, application/octet-stream)
2007-06-07 04:09 UTC, gnufied
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gnufied 2007-06-07 04:03:53 UTC
With latest build, when Ruby only IDE starts with my main project open. NBM
stays unresposive for a long time, and this too after it finishes the scanning
of project directories. Since I started NBM from terminal, it spews following
messages to the terminal:

"Too many choices! UnaryExpression : null null:
Too many choices! term$2 : null null:
Too many choices! Statement : null null:
Too many choices! Statement : <js_operator,'<'>
<js_operator,'!'>:<js_operator,'<'> <js_operator,'!'> <js_operator,'['>
<js_identifier,'CDATA'> <js_operator,'['> <js_whitespace,'\n                  
'> <js_keyword,'new'> <js_whitespace,' '> <js_identifier,'Form'> <js_operator,'.'>
Too many choices! term$2 : <css_operator,';'>
<css_identifier,'padding'>:<css_operator,';'> <css_identifier,'padding'>
<css_operator,':'> <css_number,'8px'> <css_whitespace,' '> <css_number,'0px'>
<css_whitespace,' '> <css_number,'0px'> <css_whitespace,' '> <css_number,'8px'>
Too many choices! term$2 : <css_operator,';'> null:<css_operator,';'>
Too many choices! Statement : null null:
Too many choices! Statement : <js_separator,'}'>
<js_whitespace,'\n'>:<js_separator,'}'> <js_whitespace,'\n'>
Too many choices! Statement : null null:
Too many choices! term$2 : <css_operator,';'> <css_whitespace,'
'>:<css_operator,';'> <css_whitespace,' '> <css_identifier,'padding'>
<css_operator,':'> <css_number,'0px'> <css_whitespace,' '> <css_number,'0px'>
<css_whitespace,' '> <css_number,'5px'> <css_whitespace,' '>
Too many choices! term$2 : <css_operator,';'> <css_whitespace,'
'>:<css_operator,';'> <css_whitespace,' '> <css_identifier,'background-color'>
<css_operator,':'> <css_hash,'#FFFFFF'> <css_operator,';'>
Too many choices! term$2 : <css_operator,';'>
<css_identifier,'padding'>:<css_operator,';'> <css_identifier,'padding'>
<css_operator,':'> <css_number,'10px'> <css_operator,';'>
Too many choices! UnaryExpression : null null:
Too many choices! Statement : null null:
Too many choices! Statement : <js_operator,'<'>
<js_operator,'!'>:<js_operator,'<'> <js_operator,'!'> <js_operator,'['>
<js_identifier,'CDATA'> <js_operator,'['> <js_whitespace,'\n    '>
<js_keyword,'new'> <js_whitespace,' '> <js_identifier,'Form'> <js_operator,'.'>
Too many choices! UnaryExpression : null null:
Too many choices! Statement : null null:
Too many choices! Statement : <js_operator,'<'>
<js_operator,'!'>:<js_operator,'<'> <js_operator,'!'> <js_operator,'['>
<js_identifier,'CDATA'> <js_operator,'['> <js_whitespace,'\n                  
'> <js_keyword,'new'> <js_whitespace,' '> <js_identifier,'Form'> <js_operator,'.'>
"


where terminal is gnome-terminal. I would be glad to further debug this issue,
shall i post jstack dump or something?

Status bar show -> "Opening Main Window".
Comment 1 gnufied 2007-06-07 04:09:49 UTC
Created attachment 43349 [details]
jstack dump of ide during unresponsive period
Comment 2 gnufied 2007-06-07 04:11:29 UTC
Well I have attached the jstack dump of java process, see if its of any use.
This problem is a major blocker for me right now.
Comment 3 Torbjorn Norbye 2007-06-07 04:58:59 UTC
Looks like a problem in Schliemann with the JavaScript support.

As a temporary workaround, try using another userdir (invoke with --userdir /tmp/foobar123), or 
alternatively, nuke the Windows2Local part of the userdir to prevent the IDE from reopening open files 
(likely a JavaScript file) at startup.
Comment 4 gnufied 2007-06-07 07:18:01 UTC
Yes using another user directory fixes the problem, but that way i loose my
custom snippets which now i have grown very fond of.Also removing nbproject
directory from my project fixes the issue partly. NBM still opens last opened
files, but thankfully it doesn't hang and remains responsive.

So, i think I would post tickets for two features:

1. Ability to export snippets.
2. Ability to disable opening of last opened files, during next startup. All
IDEs that i know support this feature.


If you need any further debugging information please ask, this issue is really
annoying and I am back to Emacs.
Comment 5 Torbjorn Norbye 2007-06-07 07:27:41 UTC
Try using your original userdir, but nuke config/Windows2Local/ before starting the IDE.
Comment 6 gnufied 2007-06-10 04:07:12 UTC
If programmer is trying to reproduce this, here are my steps:

1. Open a large rails project. Yes something like Mephisto would do. Choose
JRuby as Ruby version to use.
2. Open lots of views(rhtml files) in editor, specially views with some amount
of css and js embedded.
3. Open some of pure Ruby,JS and CSS files.
4. Close the IDE, by choosing exit.
5. Restart the IDE from command line and see NBM crawl.

Of course, your mileage may vary. It may be because of size of project or
something. But above steps reproduce desired effect for me.
Comment 7 Jan Jancura 2007-07-27 10:48:18 UTC
I am not sure whats happening there. Tor, why do you you think that it is in Schliemann? Do you have some more data?
jstack dump leads me to some Java parsing...
Comment 8 Jan Jancura 2007-08-02 13:30:38 UTC
> Java for evaluation
Comment 9 Jan Lahoda 2007-08-02 13:49:57 UTC
I guess Tor assigned this to Schliemann because of the "Too many choices!" messages on the terminal (not sure what they
mean).

Hanz, not sure why you think there is any Java parsing? Do you have a jstack dump different from Tor's? Could you please
attach it? Please note that the Tor's dump is (almost surely) taken from IDE without Java support (which is also the
context of the original report). If you are referring to the "GSF Source Worker Thread" from Tor's dump, please note
that this is thread that belongs to ruby/gsf, not java/source. This thread AFAICT is doing nothing, only waiting for
some work.

Sorry, but java does not seem as a correct place for this issue.
Comment 10 Jan Jancura 2007-08-02 14:12:35 UTC
"Too many choices!.." is debug message from Schliemann, but it is not connected with any issue with IDE responsiveness.
So I have not data whats happening there.

gnufied, can you please attach some more jstack dumps? What kind of files do you have opened in NetBeans during this
startup (whats the size of them, can you attach them)?
Thanks.
Comment 11 Jan Jancura 2007-08-09 12:56:26 UTC
There are no Schliemann performance specific information in this issue, so I am closing it.
We are working on JavaScript performance, and this issue is covered by several separate bugs.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo