Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 105850 - REF: Refactoring of form in desktop project should copy file resources too
REF: Refactoring of form in desktop project should copy file resources too
Status: RESOLVED DUPLICATE of bug 106831
Product: guibuilder
Classification: Unclassified
Component: Code
6.x
All Linux
: P3 (vote)
: 6.x
Assigned To: issues@guibuilder
issues@guibuilder
sp_review_61
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-06 12:28 UTC by Jiri Vagner
Modified: 2010-08-25 12:52 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
resource-files-copy.jpg (43.34 KB, image/jpeg)
2007-06-06 12:33 UTC, Jiri Vagner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Vagner 2007-06-06 12:28:38 UTC
Moving AboutBox dialog in Java Desktop Basic project to new package should copy
about.png file into new resource package of AboutDialog.
Comment 1 Jiri Vagner 2007-06-06 12:33:07 UTC
Created attachment 43294 [details]
resource-files-copy.jpg
Comment 2 Jiri Vagner 2007-06-06 12:42:42 UTC
Steps to reproduce:
 - Create Java Desktop Basic project
 - Create new package
 - Move AboutBox dialog into new package
 - Check the content of new resources subpackage

"imageLabel.icon" key in AboutBox.properties file points to about.png file, but
the package does not contain this image.
Comment 3 Tomas Pavek 2010-08-25 12:52:50 UTC
We won't implement file copying/moving, it's difficult to determine which files are needed for given GUI form by the framework, though some heuristic could be possible. But JSR-296 support is stopped.

*** This bug has been marked as a duplicate of bug 106831 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo