Bug 105808 - Overloaded marker covers syntax error marker
Overloaded marker covers syntax error marker
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Hints & Annotations
6.x
PC All
: P3 with 1 vote (vote)
: 6.x
Assigned To: Max Sauer
issues@editor
67patch1-verified
:
: 107899 111927 144268 166515 (view as bug list)
Depends on:
Blocks: 138001
  Show dependency treegraph
 
Reported: 2007-06-06 02:36 UTC by John Baker
Modified: 2009-07-16 10:19 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Baker 2007-06-06 02:36:09 UTC
If a method overloads the base method and this method has an error
such as, missing the return statement then the red squiggly lines appears.

However, no syntax error marker (red x) in the left column because
the overloaded marker covers it.
Comment 1 Vitezslav Stejskal 2007-06-08 04:41:06 UTC
Yeah, to be presice it depends on what annotation is added last. I know it's not
very convenient, but there should be a black arrow indicating that there are
more annotations on the line and if you click it it should cycle through all of
them.

Maybe we should establish some sort of priorities on what annotations should be
shown more prominently then others. Showing errors is more important than
showing wanings, which is more important than showing for example a bookmark.
Comment 2 Vitezslav Stejskal 2007-06-26 10:52:53 UTC
*** Issue 107899 has been marked as a duplicate of this issue. ***
Comment 3 Vitezslav Stejskal 2007-08-20 14:20:35 UTC
*** Issue 111927 has been marked as a duplicate of this issue. ***
Comment 4 tfrysinger 2007-08-20 14:31:41 UTC
If all methods that can be a subject of an @override (or other similar type hint) are going to show in the gutter, there
needs to be a way to remediate *all* such hints with a single action. Having to go one-by-one through 30 methods to
click on the hint and accept the action to add '@override', for example, is extremenly tedious. You should be able to
select one such hint and then indicate to NB that it should accept the hint behavior for *all* such similarly hinted
methods in the file.
Comment 5 Vitezslav Stejskal 2007-08-21 10:30:00 UTC
Agreed, CCing jlahoda, who may be able to help with this.
Comment 6 Petr Hejl 2007-10-03 09:45:47 UTC
I think this is quite important issue. What I observed is that you don't see the current line you debug if the line
contains another annotation (and that annotation was added last).

This behaviour is very confusing.
Comment 7 matthies 2008-03-18 05:43:40 UTC
Target milestone is still 6.0. Could someone please update this?
Comment 8 Max Sauer 2008-03-18 09:41:21 UTC
Setting TM to future, we won't probably implement priorities for 6.1.
Comment 9 Vitezslav Stejskal 2008-09-01 14:53:57 UTC
*** Issue 144268 has been marked as a duplicate of this issue. ***
Comment 10 Max Sauer 2008-11-13 13:36:41 UTC
Lets schedule this for next release.
Comment 11 Max Sauer 2009-06-08 13:19:37 UTC
*** Issue 166515 has been marked as a duplicate of this issue. ***
Comment 12 Max Sauer 2009-06-15 13:35:56 UTC
Priorities implemented.
---
http://hg.netbeans.org/jet-main/rev/cf6086e864c4
Comment 13 Quality Engineering 2009-06-16 19:12:40 UTC
Integrated into 'main-golden', will be available in build *200906161401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/cf6086e864c4
User: Max Sauer <msauer@netbeans.org>
Log: #105808: Implementing annotation priorities
Comment 14 Petr Blaha 2009-07-03 09:21:01 UTC
verified in the latest trunk build.
Comment 15 pgebauer 2009-07-07 12:35:49 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/b4d72ea5d53b
Comment 16 Jiri Prox 2009-07-16 10:19:08 UTC
verified in 6.7.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo