Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 105689 - mobility creates 28MB folder in userdir right after start of the IDE
mobility creates 28MB folder in userdir right after start of the IDE
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: Build System
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Adam Sotona
issues@mobility
perftest
: PERFORMANCE
Depends on: 101722
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-05 09:18 UTC by Marian Mirilovic
Modified: 2007-09-12 09:52 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2007-06-05 09:18:54 UTC
Mobility is creating 28MB folder in user directory right after startup the IDE
with new userdir, without touching any Mobility functionality :
28      ./emulators/wtk22_linux/emulator/wtk22
10      ./emulators/wtk22_linux/emulator/wtk22/docs
11      ./emulators/wtk22_linux/emulator/wtk22/bin
3       ./emulators/wtk22_linux/emulator/wtk22/lib

We also found this causes ~15 % startup regression (without WTK/with WTK) for
first start with new userdir as well as for existing userdir for big IDE :

For example:   Win XP , JDK 6.0_01       
                without WTK       with WTK
new userdir       20815             24459
existing userdir  12855             14039


BTW: this is serious problem for universities: they are used to have just one NB
installation and each student uses userdir located in her directory. So for
example for CVUT (28MB x 1000 students = 28 GB of emulators data!)
Comment 1 Martin Ryzl 2007-06-05 10:01:51 UTC
yes. It is because of wtk stores its data in the installation directory and
causes write errors and in fact prevents users from using key functionality.
This problems appears mainly in cases described in this issue, i.e. universities
with software installed in r/o locations and home directories on servers.
We have already reported the issue to the wtk team and hope it will be fixed soon.
Comment 2 Lukas Hasik 2007-06-05 10:05:53 UTC
It could be solved by the change of the emulator platform to WTK 2.5.1. There
should be a different installation model, afaik. 

Reassigning to Adam, adding dependency. 
Comment 3 Martin Ryzl 2007-06-05 10:38:59 UTC
Actually, the problem is even worse. On my machine it takes:
5.5 + WTK 2.2 - 28MB
5.5.1 + WTK 2.5.1 - 82MB

since we are going to replace 2.2 by 2.5.1 in 6.0 soon it should be marked as P1.
Comment 4 Lukas Hasik 2007-06-05 11:01:17 UTC
I increased the priority (P1) of bug reported to WTK team
(http://bt2ws.central.sun.com/CrPrint?id=6473474)
Comment 5 Adam Sotona 2007-08-16 12:21:38 UTC
we are working on the new way of installation
Comment 6 Martin Ryzl 2007-09-07 09:06:13 UTC
fixed. wtk 2.5.2 which is now bundled stores user data in user dir => no need to copy it over anymore
Comment 7 Martin Ryzl 2007-09-07 09:06:15 UTC
fixed. wtk 2.5.2 which is now bundled stores user data in user dir => no need to copy it over anymore
Comment 8 Lukas Hasik 2007-09-12 09:52:15 UTC
verified with Beta1 build 09/11


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo