Bug 105598 - Ruby Option Settings redesign
Ruby Option Settings redesign
Status: RESOLVED DUPLICATE of bug 137318
Product: ruby
Classification: Unclassified
Component: Editing
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Torbjorn Norbye
issues@ruby
http://ui.netbeans.org/docs/ui/Option...
: PLAN, UI
Depends on:
Blocks: 106376
  Show dependency treegraph
 
Reported: 2007-06-04 15:35 UTC by Josef Pavlicek
Modified: 2008-09-21 08:27 UTC (History)
4 users (show)

See Also:
Issue Type: TASK
:


Attachments
before_install (20.07 KB, image/png)
2007-06-19 16:58 UTC, Martin Krauskopf
Details
after_install (19.65 KB, image/png)
2007-06-19 16:59 UTC, Martin Krauskopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Josef Pavlicek 2007-06-04 15:35:30 UTC
Hi, I finished Ruby Option Settings redesign  (this task I received from A.
Nebuzelsky and Trung).
Please, the implementation should be finished ASAP.
Thanks
Josef Pavlicek
Comment 1 Tomas Danek 2007-06-05 13:36:44 UTC
putting also Martin to cc..
Comment 2 Torbjorn Norbye 2007-06-05 15:44:10 UTC
Unfortunately, the options area is one which wasn't implemented yet.  For Ruby we're going to have pretty 
much all the same options that are there in Java. In particular, we need a way to edit hints, occurrences 
highlighting, formatting and indentation preferences, etc.
Comment 3 Josef Pavlicek 2007-06-06 14:01:43 UTC
Hi, what it exactly means?
I designed the Ruby settings according to particular ruby settings implemented
in the current Miscellaneous. If you need more settings, we have 2 ways:

    * we are doing redesign of  languages (JSP, HTML, etc.)  They have to be
move into Editor secction
    * if you have more settings which you need implement in Miscellaneous, I can
help you to improve current spec for your needs. But I have to know what you
exactly need to have in options.

Josef. 
Comment 4 Torbjorn Norbye 2007-06-12 16:59:17 UTC
Hi Josef,
We will need pretty much all the same editor settings as those available for Java.  In other words, lots of formatting options (whitespace handling, indentation 
options, method sorting options, etc), options for which hints should be enabled/disabled and whether they apply to the whole file and selected line only, 
mark occurrences options, etc.

It's true that these are not implemented yet.  I was about to implement them based on the Java settings when I saw the new spec, so now I'm holding off to see 
what the Java module does so that the two are consistent in NB 6.
Comment 5 Torbjorn Norbye 2007-06-12 16:59:18 UTC
Hi Josef,
We will need pretty much all the same editor settings as those available for Java.  In other words, lots of formatting options (whitespace handling, indentation 
options, method sorting options, etc), options for which hints should be enabled/disabled and whether they apply to the whole file and selected line only, 
mark occurrences options, etc.

It's true that these are not implemented yet.  I was about to implement them based on the Java settings when I saw the new spec, so now I'm holding off to see 
what the Java module does so that the two are consistent in NB 6.
Comment 6 Pavel Buzek 2007-06-12 23:46:43 UTC
Oops, I did not notice there are separate issues for individual options tabs. I just committed a change to combine ruby
installation and ruby debug options. Commit log is in issue 106376.

I will keep this open to track the changes in ruby editor settings.
Comment 7 Josef Pavlicek 2007-06-13 10:59:57 UTC
Hi, I don't have more information about Ruby options still. I have only information which are collected in the UI spec.
Because we must to  have some UI imagination how the settings have to look, I'm finishing UI spec according to my
information.
Ruby Installation and Ruby Debugger will be joining into the one tab with name "Ruby". When the Ruby team will need more
options, please check all settings with me, discuss are with me and I'm sure, we can find some solution how to place it
into the Ruby panel.

Now please, continue  according to the UI spec, Ruby panel.
Thank you for cooperation
Josef Pavlicek 
Comment 8 Torbjorn Norbye 2007-06-13 15:19:12 UTC
"I don't have more information about Ruby options still": 

I said (two description entries earlier): "We will need pretty much all the same editor settings as those available for Java.  In other words, lots of formatting 
options (whitespace handling, indentation options, method sorting options, etc), options for which hints should be enabled/disabled and whether they apply 
to the whole file and selected line only, mark occurrences options, etc."

We're aiming for feature parity. While one or two options may differ, overall we need the same approach. If there is a Java category, there should be a Ruby 
category. If the Java language is in a Language combo box on a number of panels, the Ruby language should too. And so on. 
Comment 9 Josef Pavlicek 2007-06-14 07:35:28 UTC
Hi,
it's perfect. I think is good approach to add Ruby next to Java. If it means, in the Miscellaneous we will not have more
setting then now, it's perfect. If not, that is problem. So I suggest to solve this problem  "per-partes". I finalized
the UI for Ruby Installer and Debugger. If you need more settings there, let me know and we can find some good solution.
Have a nice time
Josef

-- 

Comment 10 Martin Krauskopf 2007-06-14 22:44:13 UTC
I'll also redesign Ruby Debugging part a little. Since there is not auto-detection of "rdebug-ide executable". So the
user does not need to search it manually it anymore. Also "Verbose" mode is little dangerous. Will be possibly removed
(the checkbox). Actually we might get rid of Ruby Debugging part at all, might be. Since it really depends on the chosen
interpreter. Now with fixed issue #103974 and automatic switching from slow to the fast debugger, Ruby Debugger options
might be removed....? Have to thing about it tomorrow.
I would let you know about any changes.
Comment 11 Martin Krauskopf 2007-06-14 23:07:13 UTC
"Since there is *not* auto-detection of..." should be "Since there is *now* auto-detection of..."
Comment 12 Martin Krauskopf 2007-06-19 16:57:20 UTC
I've changed the Ruby Debugger options panel. There is no need for the textfield for ruby-debug-ide executable anymore.
It is auto-detected. Also I've added "Install Fast Debugger" button into the panel. Still leaving choice to use slow
debugger if the user wants. I'll commit tomorrow if nobody is against. Thanks for possible comments. Attaching screenshots.
Comment 13 Martin Krauskopf 2007-06-19 16:58:19 UTC
Created attachment 43981 [details]
before_install
Comment 14 Martin Krauskopf 2007-06-19 16:59:00 UTC
Created attachment 43982 [details]
after_install
Comment 15 Martin Krauskopf 2007-06-20 12:02:31 UTC
Committed Ruby Debugger Options Panel simplification/enhancements.

debugger/src/org/netbeans/modules/ruby/debugger/Bundle.properties;
new revision: 1.16; previous revision: 1.15
debugger/src/org/netbeans/modules/ruby/debugger/DebuggerPreferences.java;
new revision: 1.2; previous revision: 1.1
debugger/src/org/netbeans/modules/ruby/debugger/RubyDebugger.java;
new revision: 1.36; previous revision: 1.35
debugger/src/org/netbeans/modules/ruby/debugger/RubyDebuggerOptionsPanelController.java;
new revision: 1.2; previous revision: 1.1
debugger/src/org/netbeans/modules/ruby/debugger/RubyDebuggerPanel.form;
new revision: 1.9; previous revision: 1.8
debugger/src/org/netbeans/modules/ruby/debugger/RubyDebuggerPanel.java;
new revision: 1.11; previous revision: 1.10
debugger/src/org/netbeans/modules/ruby/debugger/Util.java;
new revision: 1.22; previous revision: 1.21
debugger/test/unit/src/org/netbeans/modules/ruby/debugger/TestBase.java;
new revision: 1.18; previous revision: 1.17
Comment 16 Jiri Kovalsky 2007-07-03 13:56:26 UTC
Reassigning this issue to newly created 'ruby' component.
Comment 17 Torbjorn Norbye 2007-07-09 23:46:04 UTC
A couple of more options for Ruby I think we will need:

Method Calls:
 (*) Prefer parentheses
 ( ) Prefer spaces

This option will initially be used for code completion (see issue 108966) to decide whether to surround the arglist with spaces or parentheses, but should 
probably also be considered as a "formatting option" such that when you reformat code (as opposed to reindent code; I hope we plan to make a UI 
distinction about this not only for Ruby but for Java as well) we insert/remove parens as necessary.

A second option:

[x] Continue comments on new lines

This option will automatically insert "# " when you press return at the end of a line comment. (Ruby doesn't have block comments so this is useful for 
typing longer comment sections).

Both behaviors are currently controlled by -J-Dfoo=true flags.
Comment 18 Martin Krauskopf 2008-02-22 15:21:41 UTC
Debugger and Ruby Platforms options went somewhere else. Not sure if everything were done in editing area, reassigning.
Might be to-be-closed.
Comment 19 Lukas Hasik 2008-03-20 10:23:27 UTC
fixed?
Comment 20 jrojcek 2008-05-15 09:23:29 UTC
Can you please evaluate whether this issue has been fixed?
Comment 21 Petr Jiricka 2008-06-26 21:58:22 UTC
The editing area still needs to be redesigned according to the new UI spec:
http://ui.netbeans.org/docs/ui/options2/

However, the implementation is pretty much on the editor team side, so I am closing this as a duplicate of issue 137318,
which addresses the new options.

*** This issue has been marked as a duplicate of 137318 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo