Bug 105589 - Object Types and File Types Settings redesign
Object Types and File Types Settings redesign
Status: RESOLVED DUPLICATE of bug 133773
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Skrivanek
issues@platform
http://ui.netbeans.org/docs/ui/file_t...
: PLAN, UI
Depends on:
Blocks: 106376
  Show dependency treegraph
 
Reported: 2007-06-04 15:17 UTC by Josef Pavlicek
Modified: 2008-12-22 13:54 UTC (History)
5 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josef Pavlicek 2007-06-04 15:17:41 UTC
Hi, I finished Object Types and File Types Settings redesign  (this task I
received from A. Nebuzelsky and Trung).
Please, the implementation should be finished ASAP.
Thanks
Josef Pavlicek
Comment 1 _ rkubacki 2007-06-04 17:27:25 UTC
Ability to order object types is missing. Dtto for file types.

Open in editor: Jesse, do we really want to make it available?

I'd suggest to show icons only if there is custom icon provided.

> implementation should be finished ASAP.

It is P3/TASK.
Comment 2 Jesse Glick 2007-06-04 17:35:39 UTC
The Edit button next to Ignored Files looks useless to me. Just type in the box!

Possibly some Object Types should be concealed, e.g. "Links" as displayed in the
mockup is not something any user should edit.

File Types editing area is scary. We do not provide any kind of GUI for editing
these and the XML DTD is not documented in a place where users would find it
even if they wanted to.

IMHO: if we really want these things to be user editable, and we want it to be
friendly, we would need to do a lot better than this. Spending time implementing
the spec as given here seems wasteful to me. Would be quicker to just include
the previous Advanced Options UI here, maybe visible only after pressing an
Advanced... button or something, and wait for another release to try for a real UI.
Comment 3 _ rkubacki 2007-06-04 17:55:27 UTC
Yet another missing feature is ability to configure set of available actions for
given object type (including order and setting default action).
Comment 4 Josef Pavlicek 2007-06-06 13:37:02 UTC
Hi,
I agree with Jesse. We should improve  Files Type Editor (no only use the
NetBeans editor). I (really) discussed it in the HIE team and with developers
too. The main problem is:  now we have to move settings from Advanced Options
section (this will be moved out from NetBeans). To develop good File Types
Editor needs more time. We don't have it now. My - suggested solution, is not
Ideal I know, but we can realize it very fast and the benefit for NetBenas it
higher than to move it out from NetBeans I hope.
Comment 5 Jiri Prox 2007-09-17 20:11:59 UTC
Obsolete milestone, please reevaluate
Comment 6 Jiri Skrivanek 2008-06-14 12:57:30 UTC
Implemented as issue 133773.

*** This issue has been marked as a duplicate of 133773 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo