Bug 10462 - Problems with projects when first run as single then as multiuser - setting are not saved
Problems with projects when first run as single then as multiuser - setting a...
Status: CLOSED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
3.x
All All
: P1 (vote)
: 3.x
Assigned To: David Strupl
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-19 13:12 UTC by Jan Zajicek
Modified: 2003-07-01 14:19 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Zajicek 2001-03-19 13:12:03 UTC
Note: This problem appears in 3.1 too!

How to reproduce:

1. Unzip clean build of NB3.2.
2. start it with the '-single' switch as single user
3. made some settings
4. exit IDE
5. start the IDE normally (as multiuser)
6. * you do not see the settings from single session!
   * you do not see the projects tab
   * to open the default project from single session you have to use Project
   manager -> now you should see the the setting from the single session
   (note: in 3.1. you see the setting immediatelly after first start in multiu)
7. exit IDE
8. start IDE second time as multiuser
9. the settings from the default project from the previus session were
   disappeared!!!
Comment 1 David Strupl 2001-03-21 16:36:51 UTC
Right now there is a problem with saving the project when switching to default
project at the first start - the project is saved again just after initialSave -
but the second time it is regular save and it is no good to do regular save
when the windows are not there yet. I will examine the situation with -single.
Comment 2 David Strupl 2001-03-27 15:46:44 UTC
Fixed in [dev] and [release32].
Comment 3 Jan Zajicek 2001-03-29 12:58:10 UTC
verified in NetBeans 3.2 build # 15
Comment 4 Jan Chalupa 2001-05-06 14:27:02 UTC
Target milestone -> 3.2
Comment 5 Quality Engineering 2003-07-01 14:19:01 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo