Bug 104459 - Deadlock or infinite loop in javascript codecompletion
Deadlock or infinite loop in javascript codecompletion
Status: VERIFIED FIXED
Product: javascript
Classification: Unclassified
Component: Editor
6.x
Sun All
: P1 (vote)
: 6.x
Assigned To: issues@ide
issues@javascript
:
: 104497 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-22 00:39 UTC by _ pcw
Modified: 2009-02-27 14:26 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
ide thread stack dump (15.21 KB, text/plain)
2007-05-22 00:40 UTC, _ pcw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ pcw 2007-05-22 00:39:38 UTC
create a new js file

type //sdfsdfsdf<enter>
try to also add
/*foo
*/
or trigger code completion 
(make sure there is a comment and no js statements...

You'll get the IDE to hang.
Initially Ludo was thinking it is due to Phobos code completion, but it is
reproducible without Phobos.
Comment 1 _ pcw 2007-05-22 00:40:09 UTC
Created attachment 42626 [details]
ide thread stack dump
Comment 2 Jan Jancura 2007-05-23 13:11:29 UTC
fixed in trunk:
IDE: [5/23/07 2:11 PM] Committing "JavaScript.java" started
Checking in JavaScript.java;
/cvs/scripting/javascript/src/org/netbeans/modules/languages/javascript/JavaScript.java,v
 <--  JavaScript.java
new revision: 1.54; previous revision: 1.53
done
IDE: [5/23/07 2:11 PM] Committing "JavaScript.java" finished
Comment 3 Jan Jancura 2007-07-13 11:14:53 UTC
*** Issue 104497 has been marked as a duplicate of this issue. ***
Comment 4 Radim Roska 2007-08-07 10:01:50 UTC
VERIFIED


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo