Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 104229 - Deleting xml/xsd file -> navigator doesnt refresh
Deleting xml/xsd file -> navigator doesnt refresh
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Navigator
6.x
All All
: P2 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
:
: 98769 105175 (view as bug list)
Depends on:
Blocks: 98199 104145
  Show dependency treegraph
 
Reported: 2007-05-18 00:52 UTC by Sonali Kochar
Modified: 2008-12-22 13:36 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sonali Kochar 2007-05-18 00:52:08 UTC
Netbeans 5.5 Behavior:
1) Open a project, create a new folder
2) Create a java/Schema/XML file. Please note that this should be the only file
in the package
3) Open the file. The Navigator window shows the relevant content
4) Delete the file.
5) The Navigator is empty, displays "No view available"

Netbeans 6.0 M9 behavior:
1) Open a project, create a new folder
2) Create a java/Schema/XML file. Please note that this should be the only file
in the package
3) Open the file. The Navigator window shows the relevant content
4) Delete the file.
5) The navigaor doesn refresh and still shows the methods in case of java file,
elements in case of schema/xml file. If you double-click anywhere in the
navigator, you get the following error:

java.lang.NullPointerException
	at org.netbeans.api.java.source.UiUtils.getOffset(UiUtils.java:326)
	at org.netbeans.api.java.source.UiUtils.getOpenInfo(UiUtils.java:193)
	at org.netbeans.api.java.source.UiUtils.open(UiUtils.java:95)
	at
org.netbeans.modules.java.navigation.actions.OpenAction.actionPerformed(OpenAction.java:68)
	at org.openide.explorer.view.TreeView$PopupSupport.mouseClicked(TreeView.java:1396)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:212)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:211)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:211)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:211)
	at java.awt.Component.processMouseEvent(Component.java:5504)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3135)
	at java.awt.Component.processEvent(Component.java:5266)
	at java.awt.Container.processEvent(Container.java:1966)
	at java.awt.Component.dispatchEventImpl(Component.java:3968)
	at java.awt.Container.dispatchEventImpl(Container.java:2024)
	at java.awt.Component.dispatchEvent(Component.java:3803)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4212)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3901)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
	at java.awt.Container.dispatchEventImpl(Container.java:2010)
	at java.awt.Window.dispatchEventImpl(Window.java:1778)
	at java.awt.Component.dispatchEvent(Component.java:3803)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)


I think the Netbeans5.5 behavior was right one. If a file is deleted then the
navigator should not show the deleted file's content.
Comment 1 David Simonek 2007-05-31 16:21:19 UTC
*** Issue 105068 has been marked as a duplicate of this issue. ***
Comment 2 David Simonek 2007-05-31 16:23:36 UTC
*** Issue 105175 has been marked as a duplicate of this issue. ***
Comment 3 David Simonek 2007-06-20 18:20:44 UTC
fixed in main trunk:

Checking in NavigatorController.java;
/cvs/core/navigator/src/org/netbeans/modules/navigator/NavigatorController.java,v  <--  NavigatorController.java
new revision: 1.22; previous revision: 1.21
done
Comment 4 David Simonek 2007-06-21 10:08:36 UTC
*** Issue 98769 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo