Bug 104117 - Communication with Oracle ojdbc14.jar bug
Communication with Oracle ojdbc14.jar bug
Status: RESOLVED DUPLICATE of bug 84654
Product: db
Classification: Unclassified
Component: Code
6.x
PC Windows ME/2000
: P1 (vote)
: 6.x
Assigned To: Andrei Badea
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-16 21:31 UTC by brankop
Modified: 2007-06-18 13:46 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (41.19 KB, application/octet-stream)
2007-05-18 18:55 UTC, brankop
Details

Note You need to log in before you can comment on or make changes to this bug.
Description brankop 2007-05-16 21:31:14 UTC
To reproduce:

- create TRAVEL schema in an Oracle 9i database schema
- install Oracle ojdbc14.jar driver in Sun Application Server 9.1
- Ping in admin console to ensure ping OK
- in NB6 Runtime right click Oracle jdbc driver and select Connect
- after connecting there will be entries for Tables, Views and Stored Procedures
- Selecting Views and Stored Procedures works OK
- But selecting Tables fails. The message pops up saying "...not supported"
Comment 1 _ jimdavidson 2007-05-16 21:47:18 UTC
That message indicates a limitation in the Oracle JDBC drivers.

Which version of the drivers are you using?  You should generally use the latest
available, which is currently 10.2.0.3:

http://www.oracle.com/technology/software/tech/java/sqlj_jdbc/index.html

The newer drivers fix some problems that earlier ones had.  Please try them (if
you haven't already) and report the result.
Comment 2 Andrei Badea 2007-05-17 12:00:25 UTC
If the newest driver doesn't help please reproduce the issue with a clean
userdir and attach your message log here. Thanks.
Comment 3 brankop 2007-05-17 18:05:31 UTC
bug confirmed with latest Oracle JDBC driver 10.2.0.3

To reproduce:

-download NB6 w Sun App server 9.1
-create Oracle connection pool and JDBC resource using app server admin console
-ping to ensure connection with db works
-open NB6
-click on Runtime tab
-right click Oracle JDBC connection
-connection will be established
-clicking on Views and Stored Procedures works and metadata are shown correctly
-but clicking on Tables fails, no metadata shown and NB6 complains about
database structure saying "...unsupported feature"
Comment 4 brankop 2007-05-17 18:30:26 UTC
This bug is present only in NB6. In NB5.5, using the same Sun app server 9.1
setup, I could not reproduce it and everything worked as expected
Comment 5 brankop 2007-05-17 19:04:43 UTC
NB6 is using DB Explorer version 1.20.0.4
NB5.5 is using DB Explorer version 1.19.21.4
Comment 6 Andrei Badea 2007-05-18 10:54:22 UTC
Please reproduce the issue, right-click on the connection node in the DB
Explorer and attach here the value of the "Driver version" property. Also please
provide the information required in desc3.
Comment 7 brankop 2007-05-18 17:07:35 UTC
issue was reproduced on NB6 with two different versions of Oracle ojdbc14.jar
driver (last one was latest version 10.2.0.3)

issue cannot be reproduced with NB5.5 (DB Explorer 1.19.21.4) nor NB5.5.1
release candidate 1 (DB Explorer 1.19.30.4), only with NB6 (DB Explorer 1.20.0.4)

I uninstalled NB6 and I now work with NB5.5.1, but the pop-up message I got was:
"Error while reading database structure: unsupported feature"

This error pops up only when you try to read Tables metadata. Views and
Procedures reading work fine.

The setup of JDBC connections was: 

-two different Oracle JDBC connections targeting two different Oracle schemas.
One of these connections was based on
oracle.jdbc.pool.OracleConnectionPoolDataSource and its resource type was
javax.sql.ConnectionPoolDataSource
while other was based on oracle.jdbc.pool.OracleDataSource
and resource type javax.sql.DataSource

Other two connections were Derby database related

Same setup was also used while testing NB5.5 and NB5.5.1

Which directory you want me to delete?

Comment 8 Andrei Badea 2007-05-18 17:28:03 UTC
Start NetBeans with a command like:

netbeans -userdir "c:\temp_userdir"

then reproduce the issue and attach the file in
c:\temp_userdir\var\log\messages.log to this issue.

Also please do what I requested in desc7. I need the driver version as seen by
the DB Explorer, not what you think is the driver version. You might have an
older version of the Oracle driver in the edorsded direrctory.
Comment 9 brankop 2007-05-18 18:43:19 UTC
excerpt from messages.log:

INFO: Unsupported feature
java.sql.SQLException: Unsupported feature
	at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:134)
	at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:179)
	at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:269)
	at
oracle.jdbc.dbaccess.DBError.throwUnsupportedFeatureSqlException(DBError.java:689)
	at
oracle.jdbc.OracleDatabaseMetaData.getDatabaseMajorVersion(OracleDatabaseMetaData.java:4442)
	at
org.netbeans.lib.ddl.adaptors.DefaultAdaptor.getDatabaseMajorVersion(DefaultAdaptor.java:3967)
	at
org.netbeans.modules.db.explorer.infos.TableListNodeInfo.initChildren(TableListNodeInfo.java:49)
Caused: org.netbeans.api.db.explorer.DatabaseException: Unsupported feature
	at
org.netbeans.modules.db.explorer.infos.TableListNodeInfo.initChildren(TableListNodeInfo.java:75)
	at
org.netbeans.modules.db.explorer.infos.DatabaseNodeInfo.getChildren(DatabaseNodeInfo.java:675)
[catch] at
org.netbeans.modules.db.explorer.DatabaseNodeChildren$2.run(DatabaseNodeChildren.java:94)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:539)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:964)
Comment 10 brankop 2007-05-18 18:55:41 UTC
Created attachment 42543 [details]
messages.log
Comment 11 Andrei Badea 2007-05-21 14:02:17 UTC
Thanks. Based on the stack trace I strongly think an older driver than 10.x gets
loaded. See issue 84654 for details. You might e.g. have an older driver in the
endorsed dir.

I'm asking for the third time: "Please reproduce the issue, right-click on the
connection node in the DB Explorer and attach here the value of the "Driver
version" property."
Comment 12 Andrei Badea 2007-06-18 13:46:45 UTC
Requested info not provided for a long time. Closing as a duplicate of issue 84654.


*** This issue has been marked as a duplicate of 84654 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo