Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 10386 - ZipException: Duplicate Entry while using Writable Jar Files
ZipException: Duplicate Entry while using Writable Jar Files
Status: CLOSED WORKSFORME
Product: obsolete
Classification: Unclassified
Component: jarpackager
3.x
PC Windows ME/2000
: P2 (vote)
: 3.x
Assigned To: issues@obsolete
issues@obsolete
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-16 09:04 UTC by navneet
Modified: 2003-07-01 10:02 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description navneet 2001-03-16 09:04:18 UTC
Steps to reproduce:

1. Mount a filesystem with the sources directory
2. Mount a filesystem with the classes directory
3. Set the target for the compilation to the classes directory
4. Compile the sources such that the classes are created 
   in the classes directory
5. Create a jar file from the command line to contain all the 
   classes in classes directory
6. Mount this jar file as a wirtable jar file
   Set the cache directory of this file system to point to
   the classes directory.
7. Right click on the writable jar file system and select 
   to Update the Jar file.

This throws the following exception:

Fri Mar 16 14:34:54 GMT+05:30 2001java.util.zip.ZipException: duplicate entry: 
META-INF/MANIFEST.MF
java.util.zip.ZipException: duplicate entry: META-INF/MANIFEST.MF
        at java.util.zip.ZipOutputStream.putNextEntry(ZipOutputStream.java:165)
        at java.util.jar.JarOutputStream.putNextEntry(JarOutputStream.java:93)
        at org.netbeans.modules.jarpackager.JarCreator.doCreateJar
(JarCreator.java:429)
        at org.netbeans.modules.jarpackager.JarCreator.createJar
(JarCreator.java:107)
        at 
org.netbeans.modules.jarpackager.filesystem.WriteableJarFileSystem.createNewJar
(WriteableJarFileSystem.java:277)
        at 
org.netbeans.modules.jarpackager.filesystem.WriteableJarFileSystem.run
(WriteableJarFileSystem.java:409)
        at org.openide.filesystems.FileSystem.runAtomicAction
(FileSystem.java:371)
        at 
org.netbeans.modules.jarpackager.filesystem.WriteableJarFileSystem.updateJarFile
Content(WriteableJarFileSystem.java:399)
        at 
org.netbeans.modules.jarpackager.filesystem.UpdateWritableJarFileSystemAction.ac
tionPerformed(UpdateWritableJarFileSystemAction.java:50)
        at org.netbeans.core.ModuleActions$1.run(ModuleActions.java:76)
        at org.openide.util.Task.run(Task.java:124)
[catch] at org.openide.util.RequestProcessor$ProcessorThread.run
(RequestProcessor.java:567)
Comment 1 Jan Chalupa 2001-05-05 23:09:20 UTC
Target milestone 3.3
Comment 2 Jan Chalupa 2001-11-27 12:47:30 UTC
Target milestone -> 3.3.1.
Comment 3 brinkley 2001-12-03 11:36:35 UTC
Writeable Jar files are no longer supported in 3.3.1.
Comment 4 Quality Engineering 2003-07-01 09:57:24 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 5 Quality Engineering 2003-07-01 10:01:52 UTC
Resolved for 3.4 or earlier, no new info since then -> closing.
Comment 6 Quality Engineering 2003-07-01 10:02:45 UTC
Resolved for 3.4 or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo