Bug 103701 - Usability problems with "Deactivate"
Usability problems with "Deactivate"
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All All
: P2 (vote)
: TBD
Assigned To: Jaroslav Tulach
au-issues
: UI, UMBRELLA, USABILITY
: 103651 139779 145390 151223 153851 157873 159635 (view as bug list)
Depends on:
Blocks: 102289
  Show dependency treegraph
 
Reported: 2007-05-11 01:55 UTC by Vladimir Voskresensky
Modified: 2010-10-08 03:49 UTC (History)
6 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Voskresensky 2007-05-11 01:55:23 UTC
I've tried new Tools->Plugins manager and was confused by the
appeared/disappeared "Deactivate" button inside selected row cell. If fact it is
not seems to be usable. I'd propose to change the name of the first column from
"Uninstall" to something more neutral and add additional button "Deactivate"
inside dialog near "Uninstall" button.
Such approach has additional advantage comparing the old/new module manager: it
allows to select several plugins and then deactivate them all at once and not
one by one as it is now/was before.
Comment 1 Jiri Rechtacek 2007-05-11 09:13:07 UTC
ccing Josef as the author of UI spec.
Deactivate button is by UI design. You missed the opportunity to affect UI
review what run a month ago. Anyway, the UI will be reconsider again and matter
of Deactivate/Activate buttons should be changed. 
Comment 2 Jiri Rechtacek 2007-05-25 08:47:37 UTC
Deactivate buttons were removed. Deactivation of plugin can be invoked from
popup menu or by double click on selected plugin.
Comment 3 novakm 2007-12-04 15:00:28 UTC
I'd like to reopen this issue as I don't see any way how to deactivate more than one plugin. The only option how you can
deactivate more than one plugin is to deactivate whole category. There should be probably "Deactivate selected" in
context menu.

------
Product Version: NetBeans IDE 6.0 (Build 200711261600)
Java: 1.5.0_12; Java HotSpot(TM) Client VM 1.5.0_12-b04
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)
Comment 4 rmatous 2008-01-16 14:41:16 UTC
Chnaged to RFE because as designed
Comment 5 William Leonard 2008-01-30 20:46:18 UTC
+1. It should be possible to deactivate more then one plugin at a time. Use case: I want a Ruby only configuration of
the IDE, for which I use a separate userdir. I cannot uninstall because that effects my default configuration (userdir).
Deactivating each plugin individually is really time consuming.
Comment 6 Jiri Rechtacek 2008-08-28 10:06:52 UTC
*** Issue 145390 has been marked as a duplicate of this issue. ***
Comment 7 Jiri Rechtacek 2008-10-16 17:06:26 UTC
*** Issue 103651 has been marked as a duplicate of this issue. ***
Comment 9 Jiri Rechtacek 2008-10-16 17:09:55 UTC
*** Issue 145390 has been marked as a duplicate of this issue. ***
Comment 10 Jiri Rechtacek 2008-10-17 08:47:54 UTC
*** Issue 139779 has been marked as a duplicate of this issue. ***
Comment 11 Jiri Rechtacek 2008-10-24 07:32:36 UTC
*** Issue 151223 has been marked as a duplicate of this issue. ***
Comment 12 Antonin Nebuzelsky 2008-11-14 15:32:12 UTC
Reassigning to the new "autoupdate/*" owner dlipin.
Comment 13 dlipin 2008-11-28 08:44:02 UTC
*** Issue 153851 has been marked as a duplicate of this issue. ***
Comment 14 dlipin 2008-11-28 08:45:33 UTC
From the duplicate issue, reported by Torben (tp):

The popup menu of the plugin manager popup menu does not have a "desativate" item. Right now the deactivation button is
on the far end of the plugin manager window (upper right corner) and it is not directly associated to the plugins.

How to reproduce:
1) Select: Tools (menu) -> Plugins (menu item) -> Installed (tab)
2) Right click on a plugin to open popup menu

What happens:
The popup menu has items for deactivating category, checking and unchecking category and checking and unchecking all.

What should happen:
The popup menu should have a menu item for deactivating a single plugin.
Comment 15 Jiri Rechtacek 2008-12-19 05:41:12 UTC
Yet another VOC:
> Andreas Schneider <san@ixdb.de>
> By the way: why is the Button "Uninstall" at the bottom of the dialog and
> "Deactivate" at the right border? strange...
Comment 16 dlipin 2009-02-04 08:27:01 UTC
*** Issue 157873 has been marked as a duplicate of this issue. ***
Comment 17 Vince Kraemer 2009-02-04 14:16:53 UTC

*** This issue has been marked as a duplicate of 157873 ***
Comment 18 dlipin 2009-02-04 14:25:24 UTC
not a dup, reopening
Comment 19 dlipin 2009-02-07 14:09:31 UTC
*** Issue 157873 has been marked as a duplicate of this issue. ***
Comment 20 dlipin 2009-03-05 09:49:20 UTC
*** Issue 159635 has been marked as a duplicate of this issue. ***
Comment 21 Jaroslav Tulach 2010-10-08 03:49:51 UTC
Somebody needs to create a UI spec, get an approval for the new state and implemented. I am not going to drive this, I am almost happy with current state.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo