Bug 103294 - MalformedURLException when using JDK 1.6 and whitespaces existing in compapp project location
MalformedURLException when using JDK 1.6 and whitespaces existing in compapp ...
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: Composite Application
6.x
All All
: P1 (vote)
: TBD
Assigned To: Jun Qian
issues@soa
: RELNOTE, SPACE_IN_PATH
: 102842 102854 102863 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-04 01:00 UTC by Jun Qian
Modified: 2007-09-07 17:27 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jun Qian 2007-05-04 01:00:06 UTC
When building compapp project, sometimes an exception like the following gets
thrown:

java.net.MalformedURLException: unknown protocol: c
       at java.net.URL.<init>(URL.java:574)
       at java.net.URL.<init>(URL.java:464)
       at java.net.URL.<init>(URL.java:413)
       at
com.sun.org.apache.xerces.internal.impl.XMLEntityManager.setupCurrentEntity(XMLEntityManager.java:650)
       at
com.sun.org.apache.xerces.internal.impl.XMLVersionDetector.determineDocVersion(XMLVersionDetector.java:186)
       at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:771)
       at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
       at
com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:107)
       at
com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(DOMParser.java:225)
       at
com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(DocumentBuilderImpl.java:283)
       at javax.xml.parsers.DocumentBuilder.parse(DocumentBuilder.java:180)
       at
org.netbeans.modules.compapp.projects.jbi.anttasks.CasaBuilder.<init>(CasaBuilder.java:130)
       at
org.netbeans.modules.compapp.projects.jbi.anttasks.BuildServiceAssembly.execute(BuildServiceAssembly.java:248)
       at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
       at sun.reflect.GeneratedMethodAccessor46.invoke(Unknown Source)
       at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:597)
       at
org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
       at org.apache.tools.ant.Task.perform(Task.java:348)
       at org.apache.tools.ant.Target.execute(Target.java:357)
       at org.apache.tools.ant.Target.performTasks(Target.java:385)
       at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
       at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
       at
org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
       at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
       at
org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:256)
       at
org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:438)
       at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:129) 

The problem only occurs on JDK 1.6 where the project location contains
whitespace (i.e. C:\\Documents And
Settings\jsandusky\NetbeansProjects\SynchronousSampleApplication).

The problem does not occur at all on JDK 1.5, nor on JDK 1.6 for project
locations that do NOT contain whitespace.

Workaround: 
1. Don't have whitespace in compapp project's location if you are using JDK 1.6; 
2. Use JDK 1.5.
Comment 1 Jun Qian 2007-05-04 01:06:02 UTC
*** Issue 102842 has been marked as a duplicate of this issue. ***
Comment 2 Jun Qian 2007-05-04 01:06:42 UTC
*** Issue 102854 has been marked as a duplicate of this issue. ***
Comment 3 Jun Qian 2007-05-04 01:07:37 UTC
*** Issue 102863 has been marked as a duplicate of this issue. ***
Comment 4 Jun Qian 2007-05-04 01:28:19 UTC
Fixed in trunk.
Comment 5 Annette Wegscheider 2007-05-04 01:30:35 UTC
Added to RNs for M9:
Issue #103294: MalformedURLException exception may occur when building a
Composite Application project (using JDK 1.6) 
Description: If you use JDK 1.6 and your project path contains spaces, a
MalformedURLException may occur.

Workaround: Make sure there are no spaces in your Composite Application project
path, or switch to JDK 1.5.

Comment 6 jlautz 2007-09-07 17:27:54 UTC
Verified fixed in NB 6.0 Beta 1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo