Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 103190 - Improve usability of Output Window
Improve usability of Output Window
Status: RESOLVED DUPLICATE of bug 146627
Product: platform
Classification: Unclassified
Component: Output Window
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: t_h
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-03 02:22 UTC by _ gtzabari
Modified: 2009-11-11 04:48 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2007-05-03 02:22:12 UTC
1) Convert Output Window tabs into full fledged tabs. I'm expecting a similar
L&F. Right now they're more like dumb-down tabs and I can't use keyboard
navigation across them.

2) Add configuration option to hide "useless" tabs such as the CVS/SVN tab or
the "Debugger Console" tab. These are seem to exist purely for the sake of
debugging Netbeans' own modules and I *never* personally use them. They just get
in the way.
Comment 1 Antonin Nebuzelsky 2008-02-07 15:51:26 UTC
Reassigning to new module owner Tomas Holy.
Comment 2 Jesse Glick 2008-03-24 17:40:19 UTC
Ctrl-PageUp/Down work for me to navigate between OW tabs. Personally I never agreed with the decision to make these tabs
within a single window but perhaps the UI designers responsible for this decision can defend it.

Issue #84842 is already filed for the Debugger Console; any problems with versioning tabs should be filed separately in
an appropriate component. Please do not mix together separate issues.
Comment 3 _ gtzabari 2008-09-13 00:49:03 UTC
I am having a real difficulty when debugging web applications. Out of the five Output Window "tabs" that pop up every
time I start a debugging session, I only ever want to see one.

I filed separate issues for making these tabs hide by default but I think a much more elegant solution would be to make
these things full-fledged tabs as I mentioned before and then allow users to collapse them to the side of the output
window like you can do with existing full-fledged tabs.

Or simply do what Jesse mentioned, drop the entire concept of mini-tabs within a window (for now) and just use normal
tabs. Then in the future we can file a RFE against OpenIDE asking them to add a new mechanism which allows us to group a
collection of tabs into a single entity and allow the user to either move individual tabs independent of one another or
all at the same time.
Comment 4 t_h 2008-10-24 18:26:20 UTC
d66ef1640f63
Comment 5 t_h 2008-10-24 18:29:11 UTC
sorry, wrong issue
Comment 6 t_h 2009-11-11 04:48:11 UTC
1) dupl of issue #146627

2) debugger console can be disabled (issue #160875), VCS is partially fixed (issue #160876)

*** This bug has been marked as a duplicate of bug 146627 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo