Bug 103186 - Refreshing problem after adding or removing icon to main toolbar
Refreshing problem after adding or removing icon to main toolbar
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
: REGRESSION
: 115489 133028 144673 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-03 00:33 UTC by Ivan Sidorkin
Modified: 2009-02-19 22:53 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Sidorkin 2007-05-03 00:33:08 UTC
NetBeans IDE 6.0 Preview (M9, build 070502)
1.6.0; Java HotSpot(TM) Client VM 1.6.0-b105
Windows Vista version 6.0 running on x86
ru_RU (nb); Cp1251

- open Customize Toolbar dialog
- take any icon and drag it next to last icon on toolbar
- new icon and one existed icon disappeared (see screenshots in attachment)
- after resizing window icons become visible

another problem with removing last icon from toolbar
after removing it shows until repainting main window
Comment 1 David Simonek 2007-09-11 12:42:38 UTC
Accepted, reproduced with dragging added action to any position of last toolbar in the row. Reproduced both problems,
adding and removing as well.
Comment 2 David Simonek 2007-09-14 10:23:55 UTC
*** Issue 115489 has been marked as a duplicate of this issue. ***
Comment 3 David Simonek 2007-09-24 13:31:14 UTC
Passing to Marek...
Comment 4 mslama 2007-10-02 14:33:41 UTC
It looks like it is fixed together with issue #116559. It works fine now.
Comment 5 Ivan Sidorkin 2007-10-18 06:40:21 UTC
verified in beta2 build
Comment 6 Ivan Sidorkin 2008-01-28 18:49:18 UTC
reproduced in 
Product Version: NetBeans IDE Dev (Build 200801260000)
Java: 1.6.0; Java HotSpot(TM) Client VM 1.6.0-b105
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)

P3->P2 because of regression
Comment 7 mslama 2008-02-26 13:54:09 UTC
We cannot reproduce with today J2SE IDE trunk build both on Linux GTK L&F JDK 6u10 and WinXP with JDK 5.0u14 and JDK
6u4. I tried to Drag and Drop icons to last position on row and result was always as expected. Icon is moved and empty
space is filed ie. icons are moved to the left side. Please is it specific to any JDK version or does it happen only
with full IDE build? Does it still happen at all? Thanks.
Comment 8 Ivan Sidorkin 2008-02-26 15:47:39 UTC
Product Version: NetBeans IDE Dev (Build 200802251204)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)

reproduced at least for Attach Profiler every time
for some icons not reproduced
Comment 9 Lukas Hasik 2008-02-29 12:20:56 UTC
I'm not able to reproduce it. When do you customize the toolbar? Just after the start? During profiling/debugging? Could
you provide screenshot to show us what actually happened?

Petre, please try it on Vista.
Comment 10 Petr Chytil 2008-03-03 10:02:00 UTC
I am able to reproduce it on Vista with Attach Debugger icon, Make icon, Start Page icon,...

Product Version: NetBeans IDE Dev (Build 200803021202)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows Vista version 6.0 running on x86; Cp1250; cs_CZ (nb)
Userdir: C:\Users\Petr\.netbeans\dev
Comment 11 Lukas Hasik 2008-04-10 21:24:07 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 12 David Simonek 2008-08-25 15:37:53 UTC
*** Issue 144673 has been marked as a duplicate of this issue. ***
Comment 13 Petr Chytil 2008-09-09 12:14:18 UTC
*** Issue 133028 has been marked as a duplicate of this issue. ***
Comment 14 Antonin Nebuzelsky 2008-09-29 13:57:39 UTC
Not in 6.5 anymore -> future.
Comment 15 Stanislav Aubrecht 2008-11-28 11:36:19 UTC
should be fixed after the toolbar rewrite, please reopen if you still have problems

4f828389f2be
Comment 16 Ivan Sidorkin 2008-12-16 09:05:41 UTC
verified with NetBeans IDE Dev (Build 200812160201)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo