Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 102994 - NB M9 full ends with error [IBM JDK6]
NB M9 full ends with error [IBM JDK6]
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: Code
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: dlipin
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-30 14:51 UTC by Petr Chytil
Modified: 2019-05-14 03:24 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
installer's log (987.16 KB, text/plain)
2007-04-30 14:52 UTC, Petr Chytil
Details
this dialog jumped out after finish button was pressed (34.85 KB, application/octet-stream)
2007-04-30 14:56 UTC, Petr Chytil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Chytil 2007-04-30 14:51:12 UTC
In M9 installer:
installation ends with error on latest screen (with [finish] button)

I've got another SUNWappserver installed. That seems to be the problem (I'm not
sure of course). It's a pity, that user has no option to go one step back and
change the server settings (if this is the problem...).

IDE is installed, but some modules weren't activated during startup...
It is impossible to run uninstall script now, it says, that another installer is
running and ends with error message (I haven't tried to reboot...).

I'll try to install M9 Full with another server parameters to find out, if
SUNWappserver caused these issues...

end of log (whole log is attached):

[2007-04-30 15:19:30.246]:     executing command: chmod ugo+x
updatetool.template , in directory:
/opt/SUNWappserver_m9/updatecenter/lib/install/templates
[2007-04-30 15:19:30.258]:         [return]: 0
[2007-04-30 15:19:30.258]:     ... command execution finished
[2007-04-30 15:19:30.261]:     executing command:
/opt/SUNWappserver_m9/bin/asadmin create-domain --interactive=false --adminport
4848 --adminuser admin --passwordfile /opt/SUNWappserver_m9/nbi-19076.tmp
--instanceport 8080 --domainproperties http.ssl.port=8181
--savemasterpassword=true domain1 , in directory: /opt/SUNWappserver_m9
[2007-04-30 15:19:30.731]:         [stdout]: Exception in thread "main"
java.lang.NoClassDefFoundError: com/sun/enterprise/cli/framework/CLIMain
[2007-04-30 15:19:30.787]:         [return]: 1
[2007-04-30 15:19:30.787]:     ... command execution finished
[2007-04-30 15:19:30.789]:    
org.netbeans.installer.utils.exceptions.InstallationException: Failed to create
the default domain
[2007-04-30 15:19:30.789]:      at
org.netbeans.installer.products.sjsas.ConfigurationLogic.install(ConfigurationLogic.java:153)
[2007-04-30 15:19:30.789]:      at
org.netbeans.installer.product.components.Product.install(Product.java:263)
[2007-04-30 15:19:30.789]:      at
org.netbeans.installer.wizard.components.actions.InstallAction.execute(InstallAction.java:127)
[2007-04-30 15:19:30.789]:      at
org.netbeans.installer.wizard.components.WizardAction$1.run(WizardAction.java:103)
[2007-04-30 15:19:30.789]:     Caused by:
org.netbeans.installer.utils.applications.GlassFishUtils$DomainCreationException:
Could not create domain - the process returned 1
[2007-04-30 15:19:30.789]:      at
org.netbeans.installer.utils.applications.GlassFishUtils.createDomain(GlassFishUtils.java:100)
[2007-04-30 15:19:30.789]:      at
org.netbeans.installer.utils.applications.GlassFishUtils.createDomain(GlassFishUtils.java:67)
[2007-04-30 15:19:30.789]:      at
org.netbeans.installer.products.sjsas.ConfigurationLogic.install(ConfigurationLogic.java:144)
Comment 1 Petr Chytil 2007-04-30 14:52:19 UTC
Created attachment 41967 [details]
installer's log
Comment 2 Petr Chytil 2007-04-30 14:56:05 UTC
Created attachment 41969 [details]
this dialog jumped out after finish button was pressed
Comment 3 Petr Chytil 2007-04-30 15:41:22 UTC
Installation was successful after non-default port addresses were chosen during
the installation wizard (application server configuration part). IDE now runs
fine . So the problem is probably in another instance of application server
installed...
Comment 4 dlipin 2007-05-07 16:27:28 UTC
pchytil,

The real issue is the IBM`s java. Please correct me If I am wrong but IBM`s 
java 6 is in a preview quality (as they even call it Early Release) and there 
are several issues in it (you installation log confirms that) even though it is 
based on Sun`s jdk6u1.

So, please do not use it either for installer running (specify Sun`s java using 
--javahome /usr/java/jdk1.6.0) and for the NetBeans IDE and Application Server 
configuration.

I lowering the priority. AFAIK IBM`s java6 (and java5, and both BEA`s as well) 
are not tested either by NetBeans QA or Application Server QA.
Comment 5 dlipin 2007-06-13 16:43:41 UTC
Just a note.
I`ve installed NBI together with the latest IBM`s JDK6 (java full version "J2RE 1.6.0 IBM linux build jclxi3260-
20070508_01") and default domain was created successfully (though it was not able to start at all).

So we should contact application server team to gather the requirements on the JDK that AS can be run on.
If they say that AS can only be run on Sun`s JDK then we would filter all available JDK so that only Sun`s jdks would 
be there.
Comment 6 dlipin 2007-06-13 16:50:54 UTC
Just a note.
I`ve installed NBI together with the latest IBM`s JDK6 (java full version "J2RE 1.6.0 IBM linux build jclxi3260-
20070508_01") and default domain was created successfully (though it was not able to start at all).

So we should contact application server team to gather the requirements on the JDK that AS can be run on.
If they say that AS can only be run on Sun`s JDK then we would filter all available JDK so that only Sun`s jdks would 
be there.
Comment 7 dlipin 2007-06-22 12:45:11 UTC
Due to the information received from appserver team :
Application Server/GlassFish is tested with Sun JDK for Windows, Solaris and Linux. For MacOS, they use Apple JDK.
GlassFish does not work with IBM JDK and we they in the middle of a porting exercise to fix that. They have not tried 
porting to BEA JDK yet.

So to fix the issue we`ll need to add additional requirement for JDK (together with min and max version) - its vendor.
It should be "Sun Microsystems" until GlassFish would finished their porting.
Comment 8 dlipin 2007-07-04 14:16:17 UTC
Fixed.
I`ve added support for jdk vendor checking in JdkLocationPanel.
Now AppServer/GlassFish installation logic verify that vendor is Sun Microsystems (Apple on Mac`s).
Comment 9 samwyatt 2019-05-14 03:24:47 UTC
Installation was successful after support for jdk vendor checking was added.
https://spanishdictionary.cc/


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo