Bug 102911 - I18N - HelloWeb app doesn't accept Ja input
I18N - HelloWeb app doesn't accept Ja input
Status: RESOLVED WONTFIX
Product: javaee
Classification: Unclassified
Component: Web Project
6.x
All All
: P2 (vote)
: 6.x
Assigned To: David Konecny
issues@javaee
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-28 19:21 UTC by kaa
Modified: 2007-10-01 08:38 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
page before. See ja text in red (24.83 KB, application/octet-stream)
2007-04-28 19:22 UTC, kaa
Details
jsp after submit. Entered wasn't shown properly (30.06 KB, application/octet-stream)
2007-04-28 19:22 UTC, kaa
Details
changing encoding in browser didn't help (22.56 KB, application/octet-stream)
2007-04-28 19:23 UTC, kaa
Details
HelloWeb project (24.94 KB, application/octet-stream)
2007-04-28 19:24 UTC, kaa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaa 2007-04-28 19:21:12 UTC
build 0417 I'm running in the ja locale, using a pseudo localized netbeans.

1. Create Web App using this the following tutorial 
http://www.netbeans.org/kb/55/quickstart-webapps.html
   or use the project from attach
2. Deploy it to AS
3. Entere some Ja text in the form on web page  and press submit button.

It won't be shown properly like with eng text. Changing encoding in browser or
using IE takes no effect. On solars there is NPE on adding elements from HTML
Forms and the IDE hangs for a while. With 0424 I couldn't build the project.
Comment 1 kaa 2007-04-28 19:22:12 UTC
Created attachment 41928 [details]
page before. See ja text in red
Comment 2 kaa 2007-04-28 19:22:59 UTC
Created attachment 41929 [details]
jsp after submit. Entered wasn't shown properly
Comment 3 kaa 2007-04-28 19:23:43 UTC
Created attachment 41930 [details]
changing encoding in browser didn't help
Comment 4 kaa 2007-04-28 19:24:55 UTC
Created attachment 41931 [details]
HelloWeb project
Comment 5 Ken Frank 2007-04-29 18:14:54 UTC
This happens when the project is a web application with the jsf faces  framework
chosen in
the third panel.   Does not happen when choosing vwp jsf as framework (at least does
not happen using normal vwp activity using the pallette and dropping components onto
design area and running that.

User should not need to add language or preferred locales to browser options for
this to work;
the encoding information of the web app should handle that.
Comment 6 Ken Frank 2007-04-29 19:41:12 UTC
previous information about this issue using jsf faces framework was not correct
- the demo
used for this did not use any frameworks chosen from wizard.

running the jastrologer demo, kb/articles/Astrologer-intro.html - that project
does show multibyte ok; I realize using jsf framework is different than perhaps
doing the demo
project described  in this issue.

ken.frank@sun.com
Comment 7 Radko Najman 2007-06-27 17:03:26 UTC
Maybe I don't understand this issue but why was it reported against the web project? Web project is responsible for the
project infrastructure, for building and deploying the application, not for the runtime. If you enter Japanese text in a
running application and it is not displayed correctly, I would say it is a problem with defined encoding in the web page
or with the browser but not web project problem. Did I miss something?
Comment 8 kaa 2007-07-03 19:09:07 UTC
As far as it also happens with IE it doesn't depend on the browser.
May be the problem is in the transfer of input data from jsp page. What type of subcomponents will be the best for it?
Comment 9 David Konecny 2007-09-27 14:40:39 UTC
This is not NetBeans issue - the fact that JA text is not properly shown is because tutorial code is basic and simply
does not handle that.

I'm not expert in area of JSP encoding, but after playing a bit with the test case you provided and googling the issue I
found this thread worth reading: <http://www.theserverside.com/discussions/thread.tss?thread_id=28944>. Applying advice
given by BrandonM in <http://www.theserverside.com/discussions/thread.tss?thread_id=28944#213812> fixed the problem.
Comment 10 Ken Frank 2007-09-27 16:04:54 UTC
Could web and other samples that have jsp pages and servlets include such encoding tags in their
tutorials or other docs and in sample projects ?  the default tags could be utf-8.

We have so many users who might want to use other characters than ascii and since no tag
defaults to iso-8859-1 means that won't work.  But the simple putting in of these defaulttags as an example
along with some brief comment could really help.  (or applicable servlet code).

We could file separate issues if needed - please let me know what iz categories/subcats to use.

This could apply to sample projects also included in ide, besides those tutorials on web site.

ken.frank@sun.com
Comment 11 David Konecny 2007-10-01 08:36:17 UTC
Ken,

in this case user followed <http://www.netbeans.org/kb/55/quickstart-webapps.html> tutorial so that's the place which
could be improved.

Re. examples - web comes with 'Servlet Examples' sample project which contains (besides other things)
filter/SetCharacterEncodingFilter.java class which perhaps should be used from tutorial and that would make the
application run smoothly with non-european charsets.

Re. issuezilla comp/subcomp - I have not idea which one is right one.

David
Comment 12 David Konecny 2007-10-01 08:38:01 UTC
Btw. this link is older but explains a lot too:

<http://weblogs.java.net/blog/joconner/archive/2005/07/charset_traps.html>


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo