Bug 102669 - Instant rename does not rename javadoc parameters
Instant rename does not rename javadoc parameters
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Editor
6.x
All All
: P3 with 1 vote (vote)
: 6.x
Assigned To: Jan Pokorsky
issues@java
issue_reviewed
:
: 117883 119664 120924 124162 134344 162709 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-26 22:03 UTC by Tim Lebedkov
Modified: 2009-09-07 15:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Lebedkov 2007-04-26 22:03:17 UTC
see summary
Comment 1 m_potociar 2007-05-23 10:27:10 UTC
Is there any progress on this? I find it rather annoying that once you rename
the parameter, warning message starts to appear telling you that you should
document new parameter and another one telling you that you document a parameter
that does not exist. Rename refactoring should definitely take care of renaming
parameters, methods, classes etc. in javadoc as well.
Comment 2 m_potociar 2007-05-23 10:27:38 UTC
Adding myself to CC
Comment 3 m_potociar 2007-05-23 10:55:09 UTC
Assigning to refactoring component
Comment 4 Jan Lahoda 2007-10-05 13:25:36 UTC
*** Issue 117883 has been marked as a duplicate of this issue. ***
Comment 5 Jiri Prox 2007-10-23 08:24:44 UTC
*** Issue 119664 has been marked as a duplicate of this issue. ***
Comment 6 Jan Lahoda 2007-11-02 13:21:00 UTC
*** Issue 120924 has been marked as a duplicate of this issue. ***
Comment 7 Jan Lahoda 2007-12-17 20:55:25 UTC
*** Issue 124162 has been marked as a duplicate of this issue. ***
Comment 8 Jiri Prox 2008-04-11 00:54:19 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 9 Jiri Prox 2008-05-05 15:07:58 UTC
*** Issue 134344 has been marked as a duplicate of this issue. ***
Comment 10 Tomas Kianicka 2008-05-06 15:10:58 UTC
In version 6.1 final, the javadoc is copyied, but twice.
(Tested on pull up, push down)
Comment 11 Jan Becicka 2008-11-13 14:35:00 UTC
Many duplicates.
Comment 12 Alexei Mokeev 2009-04-14 11:02:33 UTC
Still the case for 20090414 trunk.
Comment 13 Jiri Prox 2009-04-15 12:48:13 UTC
*** Issue 162709 has been marked as a duplicate of this issue. ***
Comment 14 Jan Pokorsky 2009-09-01 18:55:14 UTC
fixed as cca4118676a8
Comment 15 Quality Engineering 2009-09-03 08:44:30 UTC
Integrated into 'main-golden', will be available in build *200909021401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/cca4118676a8
User: Jan Pokorsky <jpokorsky@netbeans.org>
Log: #102669: introducing support for javadoc parameters: instant rename, mark occurences, hyperlinking
Comment 16 Jiri Prox 2009-09-07 15:17:22 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo