Bug 102363 - I18N - cant create a junit test in other locale if junit.jar is localized
I18N - cant create a junit test in other locale if junit.jar is localized
Status: RESOLVED INVALID
Product: java
Classification: Unclassified
Component: JUnit
6.x
All All
: P2 (vote)
: TBD
Assigned To: Marian Petras
junit-issues@java
: I18N
: 104769 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-24 16:24 UTC by Ken Frank
Modified: 2007-07-24 15:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
image (124.86 KB, image/gif)
2007-04-24 16:25 UTC, Ken Frank
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2007-04-24 16:24:15 UTC
am running in ja locale, using pseudo localized nb, and am not localizing any
.template file, which are not needed to be localized as per comments from
development.

But I can't create a junit test (am using a j2se project).
see attached image with error msg.


(running in another locale for which there was no pseudo localized junit jar,
there was no error msg)


I am wondering if the code is looking for the .template file in the localized jar ?

or perhaps its something else.


It  happen if 1.3 or 1.4 is chosen, and once either 1.4 or 1.3 is chosen,
and the popup as in the attached is shown, one cannot try to create another
test in this project - one needs to start another project.
Comment 1 Ken Frank 2007-04-24 16:25:05 UTC
Created attachment 41559 [details]
image
Comment 2 Marian Petras 2007-06-22 15:56:44 UTC
*** Issue 104769 has been marked as a duplicate of this issue. ***
Comment 3 Marian Petras 2007-06-28 09:54:35 UTC
"running in another locale for which there was no pseudo localized junit jar,
there was no error msg"
--

Ken, by "pseudo localized junit jar", you mean pseudo-localized JUnit module? If so, could you send me one (or attach it
to this bug report)? Thanks.
Comment 4 Ken Frank 2007-07-18 23:37:10 UTC
Marian,

could you look at this one fairly soon ?  since it seems to be related to having localized
jar (pseudo) present, want to make sure its not something that might require
additional localized files in localized jar or some new/different values for a bundle file.

I'll send a recent pseudo localized one in separate mail.

ken.frank@sun.com
Comment 5 Marian Petras 2007-07-24 15:40:18 UTC
Confirmed on Linux (running on Intel), NetBeans build 070720, JDK 1.5.0_12. I was running on a US locale but NetBeans
was started with switch "--locale ja".

Just as I clicked on the OK button in the error dialogue, an exception message dialogue appeared:

    java.lang.NullPointerException
	at org.netbeans.modules.junit.CreateTestAction$1.run(CreateTestAction.java:218)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:539)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:964)
Comment 6 Marian Petras 2007-07-24 15:59:22 UTC
This was caused by that the pseudo-localized .jar file had pseudo-localized some entries which should not be localized
at all. In the default properties file, they look like this:

   # Test case & test suite templates for JUnit 3.x tests
   #NOI18N - this value is in .properties just to allow branding
   PROP_junit3_emptyTestClassTemplate=Templates/JUnit/EmptyJUnit3Test.java
   #NOI18N - this value is in .properties just to allow branding
   PROP_junit3_testClassTemplate=Templates/JUnit/SimpleJUnit3Test.java
   #NOI18N - this value is in .properties just to allow branding
   PROP_junit3_testSuiteTemplate=Templates/JUnit/JUnit3TestSuite.java

The corresponding comments start with "NOI18N" which means the entries should not be modified during localization process.

I mark this bug as INVALID.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo