Bug 102287 - Unworkable uninstallation in cohabitation with M8
Unworkable uninstallation in cohabitation with M8
Status: VERIFIED FIXED
Product: installer
Classification: Unclassified
Component: NBI
6.x
PC All
: P1 (vote)
: 6.x
Assigned To: dlipin
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-24 09:55 UTC by Michael Nazarov
Modified: 2007-05-25 14:35 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (6.42 KB, image/png)
2007-04-24 09:56 UTC, Michael Nazarov
Details
screensht (6.40 KB, image/png)
2007-04-30 16:53 UTC, Mikhail Vaysman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Nazarov 2007-04-24 09:55:58 UTC
I've installed M8 and latest daily build. Everything works fine. Then I've
uninstalled latest daily - OK. The I've tried to uninstall M8 - Exception and
uninstaller closed.
Second run worked fine so I decided to set priority not 1 but 2...
Comment 1 Michael Nazarov 2007-04-24 09:56:49 UTC
Created attachment 41531 [details]
screenshot
Comment 2 Michael Nazarov 2007-04-24 09:58:33 UTC
No, second run failed as well, so P1.
Comment 3 Kirill Sorokin 2007-04-24 10:27:03 UTC
Seems a duplicate of 102224.

*** This issue has been marked as a duplicate of 102224 ***
Comment 4 Michael Nazarov 2007-04-24 10:31:19 UTC
Exception looks similar but I did not touch GF in my uninstallations...
Comment 5 Kirill Sorokin 2007-04-24 10:36:22 UTC
Let's wait and see whether the fix for 102224 will correct this one as well.
I'll include your use case in the fix verification procedure.
Comment 6 Michael Nazarov 2007-04-24 10:38:34 UTC
Sure.
Comment 7 Michael Nazarov 2007-04-25 10:20:51 UTC
How is it going with verification? Build Apr 25 affected as well while other
issue marked as fixed...
Comment 8 Michael Nazarov 2007-04-30 12:55:27 UTC
Well as I can see this is not duplicate because issue still present.
Scenario looks very probable for end users who downloaded M8 and wants to update
to M9:
1. Install M8.
2. Install M9.
3. Play around starting/stopping IDEs and ASes (possible this step is not required).
3. Open Add/Remove programs.
4. Click Remove on M9 then Cancel (possible this step is not required).
5. Click Remove on M8, Uninstall.

Exception same as screenshoted already.
Comment 9 Michael Nazarov 2007-04-30 13:44:23 UTC
I checked again: additional steps are not required. M8 installation became
uninstallable immediately after M9 installation.
Comment 10 Mikhail Vaysman 2007-04-30 16:51:59 UTC
Checked for Solaris 10 x86. Issue is reproducible.
But different exception throws - NoSuchMethodError. Screenshot attached.
Comment 11 Mikhail Vaysman 2007-04-30 16:53:34 UTC
Created attachment 41976 [details]
screensht
Comment 12 Kirill Sorokin 2007-05-02 13:26:54 UTC
-> 6.0M10
Comment 13 dlipin 2007-05-02 14:48:39 UTC
Seems to be fixed, please verify on M8 and next nighly build.
Comment 14 Annette Wegscheider 2007-05-02 19:26:08 UTC
Added this item to the M9 release notes per Sergey's request. 
Issue #102287: Cohabitation issues between Milestone 8 and Milestone 9 builds.
Description: You may encounter uninstallation problems if you have NetBeans 6.0
Milestone 9 and NetBeans 6.0 Milestone 8 installed simultaneously.
Workaround: Please follow the steps described in the Troubleshooting section of
the Installation Instructions.

Comment 15 Michael Nazarov 2007-05-03 15:26:48 UTC
Reproduced with M8+May 02M9.
Comment 16 dlipin 2007-05-03 15:29:19 UTC
Mike,

As you could possible see the targeted milestone is M10.
So please verify not on the M9 installers but on the nightly build (from trunk).
Comment 17 Michael Nazarov 2007-05-03 15:31:28 UTC
Hmm, may be. I'll try then...
Comment 18 Kirill Sorokin 2007-05-08 10:10:20 UTC
No need to release note the issue as it has been fixed.
Comment 19 Annette Wegscheider 2007-05-08 16:55:23 UTC
Please be specific: has it been fixed in M9 or in M10? The Release Notes are for
M9 right now, so we need confirmation that this issue needs to be removed from
the currently posted release notes:
http://www.netbeans.org/community/releases/60/relnotes.html#known_issues-installer
Comment 20 dlipin 2007-05-08 20:15:06 UTC
Annette, as you can probably see the targeted milestone is milestone 10.

So the issue is not fixed in M9 and is not required to be removed from already 
posted release notes.
Comment 21 Mikhail Vaysman 2007-05-25 14:35:25 UTC
Verified on builds M8 and 200705250000 on Solaris x86 with JDK 1.5_11


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo