Bug 102272 - Deadlock renaming folder
Deadlock renaming folder
Status: RESOLVED DUPLICATE of bug 100582
Product: versioncontrol
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@versioncontrol
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-24 07:14 UTC by Jesse Glick
Modified: 2007-04-24 14:47 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Deadlock (10.23 KB, text/plain)
2007-04-24 07:15 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2007-04-24 07:15:01 UTC
070423. Probably not reproducible. Just trying to rename a folder with a bunch
of data files in it, in the Files tab. CVS-controlled.
Comment 1 Jesse Glick 2007-04-24 07:15:35 UTC
Created attachment 41522 [details]
Deadlock
Comment 2 Jaroslav Tulach 2007-04-24 14:47:47 UTC
This is not complete duplicate, but if issue 100582 is fixed, then this 
problem shall be prevented - the VCS will not be able to fire events in the 
deep internals of masterfs callbacks - they will be prevented by asserts.

This will indeed result in a bug against the VCS code - which will very likely 
need to rewrite following piece of code to delay the notification:

org.netbeans.api.queries.VisibilityQuery$VqiChangedListener.stateChanged(VisibilityQuery.java:138)
org.netbeans.modules.versioning.system.cvss.CvsVisibilityQuery.fireVisibilityChanged(CvsVisibilityQuery.java:95)
org.netbeans.modules.versioning.system.cvss.CvsVisibilityQuery.versioningEvent(CvsVisibilityQuery.java:71)
org.netbeans.modules.versioning.util.ListenersSupport.fireVersioningEvent(ListenersSupport.java:65)
org.netbeans.modules.versioning.util.ListenersSupport.fireVersioningEvent(ListenersSupport.java:59)
org.netbeans.modules.versioning.system.cvss.FileStatusCache.fireFileStatusChanged(FileStatusCache.java:673)
org.netbeans.modules.versioning.system.cvss.FileStatusCache.refresh(FileStatusCache.java:257)
org.netbeans.modules.versioning.system.cvss.FilesystemHandler.refresh(FilesystemHandler.java:291)
org.netbeans.modules.versioning.system.cvss.FilesystemHandler.doMove(FilesystemHandler.java:101)




*** This issue has been marked as a duplicate of 100582 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo