Bug 102244 - Can't connect to sample or travel DB
Can't connect to sample or travel DB
Status: RESOLVED WORKSFORME
Product: db
Classification: Unclassified
Component: Derby
6.x
All All
: P1 (vote)
: 6.x
Assigned To: _ jimdavidson
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-23 23:16 UTC by _ krystyna
Modified: 2007-04-24 18:11 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Exception stack from failed connect to sample app, travel db (4.32 KB, application/octet-stream)
2007-04-23 23:25 UTC, _ krystyna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ krystyna 2007-04-23 23:16:23 UTC
NB installer 04023 (standard)

XP
JDK1.6

1. rebooted machine, created EE5 project
2. started DB server from Tools menu. ok:

Apache Derby Network Server - 10.2.1.0 beta started and ready to accept
connections on port 1527 at 2007-04-23 21:54:06.375 GMT 

(also: netstat shows tcp port 1527 is listening)

3. in runtime tab, databases/drivers/ see sample and travel .
right click on travel, get connect dialog and provided travel password


get Error dialog:

Unable to establish a connection to jdbc:derby://localhost:1527/travel using
org.apache.derby.jdbc.clientDriver (DERBY SQL error: SQLCODE :-1 SQLSTATE:
XJ040, SQLERRMC: failed to start database 'travel', see the next exception for
details.

Same for connect attempt to sample app/app db.

Attaching connection for log.
Comment 1 _ krystyna 2007-04-23 23:25:39 UTC
Created attachment 41506 [details]
Exception stack from failed connect to sample app, travel db
Comment 2 John Baker 2007-04-24 00:20:41 UTC
is this with a new userdir or reusing?
Comment 3 Andrei Badea 2007-04-24 10:17:34 UTC
This could be caused by the beta version ("10.2.1.0 beta") you are using. Try
updading to a stable version of Java DB. You can register it in Tools - Options
- Advanced Options - Server and External Tool Settings - Java DB Database - Java
DB Location. Or you can just start with a clean userdir on JDK 1.6.0 final.
Comment 4 _ krystyna 2007-04-24 17:28:05 UTC
This is with a new userdir, not importing any settings.
My jdk is 1.6.0-rc-b100.

I removed.netbeans-derby and -.netbean-derby.bak too prior to 
starting IDE with new userdir. Java DB started ok , but after
typing password to connect still failed (same error). Can I 
re-direct the default .netbeans-derby to a different location?


Comment 5 Petr Jiricka 2007-04-24 17:37:28 UTC
b100 is not the final build of JDK 6. Please use either the final build of JDK 6
or the final build of JDK 6 u1.
Comment 6 _ krystyna 2007-04-24 17:57:01 UTC
Upgraded to jdk1.6_01; removed .netbeans-derby;
started with fresh userdir, no import settings.
It worked! Thanks. Got connected to both sample
app and travel. Closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo