Bug 101843 - Java editor should provide up-to-date status in the error stripe
Java editor should provide up-to-date status in the error stripe
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All All
: P4 (vote)
: 6.x
Assigned To: Jan Jancura
issues@editor
CLEAN
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-19 21:47 UTC by Jesse Glick
Modified: 2009-12-21 05:50 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2007-04-19 21:47:26 UTC
070419. Until recently, when you opened a source file, its status box was
initially green until it was parsed, which was of course wrong. Now it correctly
shows the little clock icon, which is fine - but it does not automatically
change this icon when parsing finishes. You need to type some character and undo
it to force it to update to a color (green/yellow/red).

Interestingly, in the case of r/o classes (e.g. JDK sources), you can just type
any character - the status line will say the file is r/o, then the parser color
will update!
Comment 1 Jan Lahoda 2007-04-20 08:28:45 UTC
The problem with "parsing" status has the same root cause as issue #100815
(languages/engine creates an UpToDateStatusProvider for Java). There is no
"native" up-to-date status provider for Java now. I propose to change the scope
of this issue to create a native UtDSP for Java.

Re: r/o sources - the editor document is not truly read-only, if a change is
made to a "read-only" document, it is automatically "undo-ed".
Comment 2 Jiri Prox 2008-04-11 00:53:17 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 3 Jan Becicka 2008-08-05 14:31:09 UTC
P4 imo
Comment 4 Jan Lahoda 2008-11-18 16:26:52 UTC
Will belong to Parsing API.
Comment 5 Quality Engineering 2009-12-21 05:50:04 UTC
This bug was reported against NetBeans IDE 6.0 or an older release, or against a non-maintained module. NetBeans team does not have enough resources to get to this issue, therefore we are closing the issue as a WONTFIX. If you are interested in providing a patch for this bug, please see our NetFIX guidelines for how to proceed. 

We apologize for any inconvenience.


Thank you.
The NetBeans Team


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo