Bug 10174 - Products with empty description are not displayed in the "products" page.
Products with empty description are not displayed in the "products" page.
Status: RESOLVED INVALID
Product: obsolete
Classification: Unclassified
Component: collabnet
3.x
Other Other
: P1 (vote)
: TBD
Assigned To: issues@www
issues@www
:
Depends on:
Blocks: 9556
  Show dependency treegraph
 
Reported: 2001-03-12 15:04 UTC by Jan Chalupa
Modified: 2009-11-08 02:27 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Chalupa 2001-03-12 15:04:26 UTC
I'm not able to edit products that have empty description fields in IssueZilla. 
The products are not shown in

http://www.netbeans.org/issues/editproducts.cgi

and there doesn't seem to be any other way to access them via the IssueZilla 
admin interface. It is possible to file bugs against those modules though as 
they are displayed in

http://www.netbeans.org/issues/enter_bug.cgi

Examples of the modules with empty descriptions include:

cpplite
logger
jasm
vcscore
Comment 1 rbalada 2001-03-12 16:13:16 UTC
The problem is that someone forgot to enter description of product and SQL 
select in editproducts.cgi lines 207-212 (as in Bugzilla 2.10) cannot work with 
NULL fields.

There are two possible solutions easier and (of course) more complicated:

The easier way is to manualy update affected NULL fields using SQL "update" 
command (I recommend it).

The more complicated way is to rewrite SQL select in editproducts.cgi lines 
207-212 to handle also records with NULL fields.

Another case is to fix database structure shown in checksetup.pl lines 665-666.
Comment 2 Unknown 2001-03-13 22:57:26 UTC
Done.  Every product is in there with "default text".  Please change when you 
get a chance.
Added:
cpplite
itutor
jasm
logger
nbbuild
qa
vcscore

in tigris products table:
insert into products values("vcscore","default text","",0,0);
in issues product table:
insert into products values("vcscore","default text","",0,0,10000,0,"");
for future reference.
This is what lead me to the answer
ON products.product=issues.product
line 225 in editcomponents.cgi.
Rudolf was entirely right except the entries just didn't exist rather than 
existed with some NULL values in them.
Comment 3 Jesse Glick 2001-03-14 14:32:26 UTC
Keri, since most of these projects were created via SourceCast admin interface,
isn't it a SourceCast bug that the bug database's metadata was not fully updated
after creating each project?
Comment 4 Unknown 2001-03-14 21:24:54 UTC
This is actually the Tigris infrastructure and at that point, Bug/Issuezilla 
wasn't as integrated as it is in Sourcecast -- so it has to be manual.
Comment 5 Marian Mirilovic 2009-11-08 02:27:27 UTC
We recently moved out from Collabnet's infrastructure


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo