Bug 101212 - rename refactoring deletes code
rename refactoring deletes code
Status: VERIFIED FIXED
Product: javascript
Classification: Unclassified
Component: Editor
6.x
All Windows XP
: P1 (vote)
: 6.x
Assigned To: Daniel Prusa
issues@javascript
:
: 101174 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-16 19:27 UTC by Pavel Buzek
Modified: 2009-02-27 14:26 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Buzek 2007-04-16 19:27:07 UTC
I have a javascript file with this content:
            function foo () {
            
            }
            function bar() {
            foo()
            }

I step on foo() (I tried both on the first line or on the 5th line) and I select
menu Refactoring | Rename. I get a dialog asking for name, I type something
("ahoj") and the result is that the whole file looks like this:
            ahojfunction bar() {
            foo()
            }
Comment 1 Daniel Prusa 2007-04-17 13:32:19 UTC
reproducible, bounds in refactoring element have to be set for function name only
Comment 2 Daniel Prusa 2007-04-17 13:33:54 UTC
*** Issue 101174 has been marked as a duplicate of this issue. ***
Comment 3 Daniel Prusa 2007-04-17 15:15:41 UTC
Fixed.
Comment 4 Radim Roska 2007-08-07 09:38:33 UTC
VERIFIED


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo