Bug 101174 - Rename on method destroys the method
Rename on method destroys the method
Status: VERIFIED DUPLICATE of bug 101212
Product: javascript
Classification: Unclassified
Component: Editor
6.x
All All
: P1 (vote)
: TBD
Assigned To: issues@ide
issues@javascript
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-16 15:55 UTC by Martin Schovanek
Modified: 2009-02-27 14:26 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Schovanek 2007-04-16 15:55:04 UTC
[#200704151800, jdk1.5.0]

to reproduce:
-------------
1) type in a .js file:
  function foo (parameter) {
      return i;
  }
  foo('a');
2) right click the foo on foo('a'); line
3) rename it to foo2
ERROR: IDE refactor the whole code to:
  foo2foo('a');
Comment 1 Daniel Prusa 2007-04-17 13:34:01 UTC

*** This issue has been marked as a duplicate of 101212 ***
Comment 2 Radim Roska 2007-08-07 09:45:55 UTC
VERIFIED


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo