Bug 100718 - Fail to build a Web Service Client in a WebAppliation.
Fail to build a Web Service Client in a WebAppliation.
Status: VERIFIED FIXED
Product: webservices
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P1 (vote)
: 6.x
Assigned To: Roderico Cruz
issues@webservices
ENTPACT_TUT, PREVIEW_STOPPER
: SPACE_IN_PATH
: 99751 (view as bug list)
Depends on:
Blocks: 102436
  Show dependency treegraph
 
Reported: 2007-04-12 02:12 UTC by _ hong_lin
Modified: 2007-06-11 20:33 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Sample Applications (35.41 KB, application/x-compressed)
2007-04-12 02:13 UTC, _ hong_lin
Details
Many Exceptions were found in Messages.log file (69.49 KB, text/plain)
2007-04-12 02:15 UTC, _ hong_lin
Details
The WebApplication1 project (25.66 KB, application/x-compressed)
2007-04-12 02:16 UTC, _ hong_lin
Details
Log file (not able to add web service client) (44.41 KB, text/plain)
2007-04-12 19:30 UTC, Annette Wegscheider
Details
Detail Error message (21.67 KB, image/png)
2007-04-27 01:17 UTC, _ hong_lin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ hong_lin 2007-04-12 02:12:36 UTC
Build: Hula daily build 200704101900

Steps to reproduce it:

1. In IDE, open project LoanProcessor, LoanRequestor and
LoanRequestorCompositeApp(They are in the attached LoanProcessing1.zip file).
You may need to resolve the reference manually.
2. Deploy EJB Module LoanProcessor.
3. Deploy Composite Application LoanRequestorCompositeApp.
4. Create a new Web Application WebApplication1 (accept all default settings).
   The Projects window now contains a project node for a web service client
called WebApplication1.
5. In the Projects window, right-click the WebApplication1 project node and
choose New > Web Service Client.
6. Click Next.
7. In the WSDL and Client Location page, select the Local File option.
8. Click the Browse button.
9. In the Open dialog box, navigate to and select the LoanRequestor.wsdl file
under <path-to-project-folder>\LoanRequestor\src.
10. Click Open.
11. In the Package field, type wsclient.
12. Click Finish.

Got the following error messages in the Output window and build failed.
Messages.log will be attached.:
init:
wsimport-init:
Created dir: C:\Documents and Settings\Hong\My
Documents\NetBeansProjects\WebApplication1\build\generated\wsimport\client
Created dir: C:\Documents and Settings\Hong\My
Documents\NetBeansProjects\WebApplication1\build\generated\wsimport\binaries
wsimport-client-check-LoanRequestor:
wsimport-client-LoanRequestor:
Consider using <depends>/<produces> so that wsimport won't do unnecessary
compilation
command line: wsimport -d "C:\Documents and Settings\Hong\My
Documents\NetBeansProjects\WebApplication1\build\generated\wsimport\binaries"
-extension -keep -s "C:\Documents and Settings\Hong\My
Documents\NetBeansProjects\WebApplication1\build\generated\wsimport\client"
-catalog "C:\Documents and Settings\Hong\My
Documents\NetBeansProjects\WebApplication1\catalog.xml" -verbose "C:\Documents
and Settings\Hong\My
Documents\NetBeansProjects\WebApplication1/src/conf/xml-resources/web-service-references/LoanRequestor/wsdl/LoanRequestor.wsdl"
-p wsclient -wsdllocation
file:/C:/Documents%20and%20Settings/Hong/LoanHula/Loan.Hong/LoanProcessing1/LoanRequestor/src/LoanRequestor.wsdl
parsing WSDL...


generating code...
wsclient\LoanRequestorPortType.java
wsclient\LoanRequestorService.java
wsclient\ObjectFactory.java
wsclient\ProcessApplicationResponseType.java
wsclient\ProcessApplicationType.java
wsclient\package-info.java
C:\Documents and Settings\Hong\My
Documents\NetBeansProjects\WebApplication1\build\generated\wsimport\client\wsclient\LoanRequestorPortType.java:9:
cannot find symbol
symbol  : class XmlSeeAlso
location: package javax.xml.bind.annotation
import javax.xml.bind.annotation.XmlSeeAlso;
C:\Documents and Settings\Hong\My
Documents\NetBeansProjects\WebApplication1\build\generated\wsimport\client\wsclient\LoanRequestorPortType.java:20:
cannot find symbol
symbol: class XmlSeeAlso
@XmlSeeAlso({
C:\Documents and Settings\Hong\My
Documents\NetBeansProjects\WebApplication1\build\generated\wsimport\client\wsclient\LoanRequestorService.java:10:
cannot find symbol
symbol  : class WebServiceFeature
location: package javax.xml.ws
import javax.xml.ws.WebServiceFeature;
C:\Documents and Settings\Hong\My
Documents\NetBeansProjects\WebApplication1\build\generated\wsimport\client\wsclient\LoanRequestorService.java:62:
cannot find symbol
symbol  : class WebServiceFeature
location: class wsclient.LoanRequestorService
    public LoanRequestorPortType getLoanRequestorPort(WebServiceFeature...
features) {
4 errors
compilation failed, errors should have been reported
C:\Documents and Settings\Hong\My
Documents\NetBeansProjects\WebApplication1\nbproject\build-impl.xml:308:
wsimport failed
BUILD FAILED (total time: 3 seconds)
Comment 1 _ hong_lin 2007-04-12 02:13:26 UTC
Created attachment 40782 [details]
Sample Applications
Comment 2 _ hong_lin 2007-04-12 02:15:27 UTC
Created attachment 40783 [details]
Many Exceptions were found in Messages.log file
Comment 3 _ hong_lin 2007-04-12 02:16:44 UTC
Created attachment 40784 [details]
The WebApplication1 project
Comment 4 _ hong_lin 2007-04-12 02:19:38 UTC
This bug affects Enterprise Pack tutorial "Creating a Loan Processing Composite
Application". Have to be fixed for J1 Preview release.
Comment 5 Lukas Jungmann 2007-04-12 08:44:10 UTC
Seems to be the same as issue 98934.
What is version/build number of the GlassFish server you use, please?
Comment 6 _ hong_lin 2007-04-12 08:48:28 UTC
glassfish-v2-b41a
Comment 7 Lukas Jungmann 2007-04-12 13:13:11 UTC
Followed described steps with own fresh hula build on jdk6 and gf-v2-b41a, but I
still cannot reproduce this :(

Exceptions from the log are not related to this issue and they have been already
reported AFAIK.

Could you try to reproduce this if there are no spaces in path to any component
(ie. have ide in c:\ide, glassfish in c:\glassfish and projects in c:\projects),
please?
Comment 8 Annette Wegscheider 2007-04-12 18:39:13 UTC
Installed fresh build (from
http://bits.nbextras.org/netbeans/6.0/nightly/20070412/installers/netbeans-6.0-full-20070412-windows.exe)
with no spaces in any of the installation/project paths and could not reproduce.
Build info: 
NetBeans IDE Dev (Build 070412)
1.6.0; Java HotSpot(TM) Client VM 1.6.0-b105
Windows XP version 5.1 running on x86
en_US (nb); Cp1252

Will now restart installation with spaces in installation path and try to reproduce.
Comment 9 Annette Wegscheider 2007-04-12 19:28:57 UTC
Clean install into path with spaces:
NetBeans IDE Dev (Build 070412)
1.6.0; Java HotSpot(TM) Client VM 1.6.0-b105
Windows XP version 5.1 running on x86
en_US (nb); Cp1252

IDE + Packs: C:\Program Files\netbeans-6.0-20070412
GlassFish: C:\Program Files\glassfish-v2-b41a
Projects: C:\Documents and Settings\aw152234\My Documents\NetBeansProjects

Attached log file (aw-log-20070412.txt) because the BUILD FAILED. Same result in
Output window as Hong reported initially. 

Comment 10 Annette Wegscheider 2007-04-12 19:30:07 UTC
Created attachment 40845 [details]
Log file (not able to add web service client)
Comment 11 Roderico Cruz 2007-04-13 00:02:52 UTC
This happens when Glassfish is installed in a directory that has embedded spaces
in Windows. The classpath to the jaxws jars are in Glassfish and this seems to
be the cause of this problem.
Workaround is to deploy Glassfish in a directory that has no embedded spaces.
Since there is a workaround, downgrading this to a P2.
Comment 12 Lukas Jungmann 2007-04-13 02:23:01 UTC
*** Issue 99751 has been marked as a duplicate of this issue. ***
Comment 13 Jaroslav Pospisil 2007-04-19 13:03:34 UTC
This is Glassfish issue http://www.netbeans.org/issues/show_bug.cgi?id=100718 .
Comment 14 Jaroslav Pospisil 2007-04-19 13:08:09 UTC
Sorry for mistake - i meant of course issue
https://glassfish.dev.java.net/issues/show_bug.cgi?id=2866
Comment 15 Jaroslav Pospisil 2007-04-24 10:56:51 UTC
Problem is now reproducible in latest NB6.0 daily build(200704231800) with
Tomcat 5.5. When IDE is installed in path with spaces (default Program Files
path in WinXP,for example), I'll get the same result as here,no matter if Tomcat
has or hasn't spaces in its own installation path. Raising priority to P1.
Comment 16 Srividhya Narayanan 2007-04-24 17:37:43 UTC
Why is the blocking glassfish issue marked as P2 and not a P1?
Comment 17 Roderico Cruz 2007-04-24 17:40:28 UTC
It's now a P1.
Comment 18 Roderico Cruz 2007-04-25 08:10:30 UTC
I think the problem with Tomcat is a different issue, the cause of which is an
error in the build-impl.xsl script. Will fix this error.
Comment 19 Jaroslav Pospisil 2007-04-25 08:57:43 UTC
OK,I'll file Tomcat problem in separate issue and set the dependence.
Glassfish issue is now raised to P1 and reopened,since I'm able to reproduce the
problem even with new b41d build.
Comment 20 Jaroslav Pospisil 2007-04-25 09:07:25 UTC
Tomcat issue was filled as http://www.netbeans.org/issues/show_bug.cgi?id=102436 .
Comment 21 Roderico Cruz 2007-04-25 20:22:00 UTC
For JDK 1.6, the workaround for now is:
1. Go to the Glassfish/lib/endorsed dir
2. copy webservices-api.jar to <jdk-1.6-dir>/jre/lib/endorsed directory. If
there is no endorsed directory, create one.
Note that this is temporary so that testing can proceed. we are still looking
for a permanent solution.
Comment 22 Roderico Cruz 2007-04-26 07:04:23 UTC
This has been identified by the jaxws team  as a bug in the xendorsed option of
wsimport. The jaxws group has a fix for this, however, it will not be available
until jaxws 2.1.2. See Vivek's note in
https://glassfish.dev.java.net/issues/show_bug.cgi?id=2866.
As such, we recommend the workaround that was previously mentioned or install
Glassfish in a path with no spaces. Since the fix is coming from the jaxws team,
 we are requesting for a waiver on this bug.
Comment 23 Srividhya Narayanan 2007-04-26 07:21:54 UTC
The jaxws 2.1.2 is expected to be integrated in glasfish by mid May so we will
be able to have this resolved without the workaround by M10.
Comment 24 Petr Blaha 2007-04-26 16:26:31 UTC
No objections to waive. Marking as waiver approved for M9.
Comment 25 _ hong_lin 2007-04-27 01:16:59 UTC
In build 0704261200, I got a different error message:

Web Service Client can not be created by JAXWS:wsimport utility.

Since I can't copy and paste the error messages, please check the screen shot
ErrorDialog.PNG.

Comment 26 _ hong_lin 2007-04-27 01:17:03 UTC
Created attachment 41780 [details]
Detail Error message
Comment 27 Roderico Cruz 2007-04-27 01:27:45 UTC
Hong,
That error has nothing to do with this issue. The problem is that you are trying
to create a client from an abstract WSDL (no bindings, etc) which is not allowed
in JAXWS.
Comment 28 Lukas Jungmann 2007-05-22 16:54:42 UTC
An issue with space in path is already fixed/verified in gf-v2-b47 => closing
this as fixed.
Comment 29 Lukas Jungmann 2007-06-11 20:33:18 UTC
Jarda already verified this some time ago => v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo