Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 100582 - Prevent reentrant calls from ProvidedExtensions
Prevent reentrant calls from ProvidedExtensions
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Filesystems
6.x
All All
: P2 (vote)
: 6.x
Assigned To: rmatous
issues@platform
:
: 102272 (view as bug list)
Depends on:
Blocks: 97278
  Show dependency treegraph
 
Reported: 2007-04-11 10:25 UTC by Maros Sandor
Modified: 2008-12-22 11:38 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maros Sandor 2007-04-11 10:25:10 UTC
Prevent calls back to filesystems from registered ProvidedExtensions handlers.
Comment 1 Jaroslav Tulach 2007-04-24 14:47:41 UTC
*** Issue 102272 has been marked as a duplicate of this issue. ***
Comment 2 Jesse Glick 2007-04-24 18:23:15 UTC
See deadlock in issue #102272.
Comment 3 rmatous 2007-06-28 11:28:12 UTC
/cvs/openide/masterfs/src/org/netbeans/modules/masterfs/Cache.java,v  <--  Cache.java
new revision: 1.8; previous revision: 1.7

/cvs/openide/masterfs/src/org/netbeans/modules/masterfs/ProvidedExtensionsProxy.java,v  <--  ProvidedExtensionsProxy.java
new revision: 1.7; previous revision: 1.6

/cvs/openide/masterfs/src/org/netbeans/modules/masterfs/MasterURLMapper.java,v  <--  MasterURLMapper.java
new revision: 1.17; previous revision: 1.16


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo