Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 10035 - Attach... action is still disabled.
Attach... action is still disabled.
Status: CLOSED FIXED
Product: debugger
Classification: Unclassified
Component: Code
3.x
PC All
: P1 (vote)
: 3.x
Assigned To: Daniel Prusa
issues@debugger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-07 11:57 UTC by Jan Stola
Modified: 2003-06-30 17:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Stola 2001-03-07 11:57:56 UTC
Pilsen (build 010306) and Netbeans (build 139)
==============================================

Steps to reproduce:
-------------------
1. Start IDE
2. Look at the Debug menu or Debug (Full) toolbar.
Comment 1 Jan Jancura 2001-03-08 10:08:39 UTC
Assigned
Comment 2 Jan Jancura 2001-03-08 12:44:51 UTC
Assigned
Comment 3 Jan Chalupa 2001-03-12 08:58:22 UTC
Version: 'Dev' -> 3.2
Comment 4 Daniel Prusa 2001-03-15 15:06:38 UTC
[main trunk, NB3.2]
Comment 5 Jan Stola 2001-03-16 08:47:59 UTC
Verified in Pilsen (build 010315) and Netbeans release 3.2 (build 6)
Comment 6 wnichols 2001-03-16 16:26:48 UTC
I installed development build 147 because the release notes indicated the but
10035 was fixed.  When I attempt to attach to a debug vm I got the following
exception.

Fri Mar 16 09:40:26 GMT-07:00 2001java.lang.ClassCastException: null
Annotation: Exception occurred in Request Processor
Nested annotation:
org.netbeans.modules.debugger.delegator.DelegatingDebuggerImpl
org.openide.util.RequestProcessor$Holder(task
org.netbeans.core.ModuleActions$1@706ab7 [-4726, 1])
        at
org.openide.util.RequestProcessor$Task.createHolder(RequestProcessor.java:274)
        at org.openide.util.RequestProcessor.post(RequestProcessor.java:98)
        at org.openide.util.RequestProcessor.post(RequestProcessor.java:71)
        at org.netbeans.core.ModuleActions.invokeAction(ModuleActions.java:89)
        at
org.openide.awt.Actions$ButtonBridge.actionPerformed(Actions.java:343)
        at
javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1450)
        at
javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(AbstractButton.java:1504)
        at
javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:378)
        at
javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:250)
        at javax.swing.AbstractButton.doClick(AbstractButton.java:279)
[catch] at
javax.swing.plaf.basic.BasicMenuItemUI$MouseInputHandler.mouseReleased(BasicMenuItemUI.java:886)
        at java.awt.Component.processMouseEvent(Component.java:3717)
        at java.awt.Component.processEvent(Component.java:3546)
        at java.awt.Container.processEvent(Container.java:1164)
        at java.awt.Component.dispatchEventImpl(Component.java:2595)
        at java.awt.Container.dispatchEventImpl(Container.java:1213)
        at java.awt.Component.dispatchEvent(Component.java:2499)
        at
java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:2451)
        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:2216)
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:2125)
        at java.awt.Container.dispatchEventImpl(Container.java:1200)
        at java.awt.Window.dispatchEventImpl(Window.java:912)
        at java.awt.Component.dispatchEvent(Component.java:2499)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:333)
        at
java.awt.EventDispatchThread.pumpOneEvent(EventDispatchThread.java:103)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:84)
 
Fri Mar 16 09:40:26 GMT-07:00 2001java.lang.ClassCastException:
org.netbeans.modules.debugger.delegator.DelegatingDebuggerImpl
java.lang.ClassCastException:
org.netbeans.modules.debugger.delegator.DelegatingDebuggerImpl
        at
org.netbeans.modules.debugger.support.actions.ConnectAction.performAction(ConnectAction.java:54)
        at
org.openide.util.actions.CallableSystemAction.actionPerformed(CallableSystemAction.java:66)
        at org.netbeans.core.ModuleActions$1.run(ModuleActions.java:76)
        at org.openide.util.Task.run(Task.java:124)
[catch] at
org.openide.util.RequestProcessor$ProcessorThread.run(RequestProcessor.java:567)
Comment 7 wnichols 2001-03-16 16:37:45 UTC
I have confirmed that the above issue exists with beta 3.6 build 6
Comment 8 Jan Stola 2001-03-16 16:44:06 UTC
This bug was fixed in Netbeans release 3.2 (build 6).
Comment 9 Jan Stola 2001-03-16 16:46:26 UTC
Verified in Pilsen (build 010315) and Netbeans release 3.2 (build 6).

The description of another bug that arises by enabling Attach action
is duplicate of issue 10382.
Comment 10 Jan Chalupa 2001-05-05 21:29:23 UTC
Target milestone -> 3.2
Comment 11 Quality Engineering 2003-06-30 17:29:19 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo