Bug 100225 - cc in embedded js- hiding after typing a letter
cc in embedded js- hiding after typing a letter
Status: VERIFIED FIXED
Product: web
Classification: Unclassified
Component: HTML Editor
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Marek Fukala
Jindrich Sedek
EMBEDDING, J1_STOPPER
:
Depends on: 101620
Blocks: 99509
  Show dependency treegraph
 
Reported: 2007-04-06 14:41 UTC by Lukasz Grela
Modified: 2009-05-18 10:47 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
The patch (1.52 KB, patch)
2007-04-25 17:33 UTC, Marek Fukala
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lukasz Grela 2007-04-06 14:41:30 UTC
1) invoke cc in embedde js block (ctrl+space)
2) type "A" -> instead of show all Items starting with "A" it showing "no
suggestion"
Comment 1 Jindrich Sedek 2007-04-18 14:02:40 UTC
The same problem appears for embedded CSS style
Comment 2 Marek Fukala 2007-04-24 14:48:27 UTC
This issue partially depends on issue #101620
Comment 3 Martin Schovanek 2007-04-24 14:59:54 UTC
It is very visible issue, increasing priority to P1, should be fixed for M9.
Comment 4 Marek Fukala 2007-04-25 17:30:05 UTC
The problem is in fact in the Schliemann CompletionProvider implementation of
CompletionTask.refresh() method. The method doesn't introspect embedded
languages when refreshing results. 

I have made a simple patch and attached it to this issue. However I am affraid
of doing such changes in the generic Schliemann code, especially now in M9 HR,
so I would like to ask Hanz to review and possibly apply it and close this
issue. If the patch is completely wrong, please reassign the issue to you and
fix as you wish.

Thanks.
Comment 5 Marek Fukala 2007-04-25 17:33:35 UTC
Created attachment 41650 [details]
The patch
Comment 6 Jan Jancura 2007-04-26 12:27:31 UTC
This fix looks safe. Feel free to check it to cvs.
Comment 7 Marek Fukala 2007-04-26 12:47:05 UTC
ok then, fixed

Checking in CompletionProviderImpl.java;
/cvs/languages/engine/src/org/netbeans/modules/languages/features/CompletionProviderImpl.java,v
 <--  CompletionProviderImpl.java
new revision: 1.17; previous revision: 1.16
done
Comment 8 Jindrich Sedek 2007-07-04 09:59:24 UTC
verified.
NetBeans IDE Dev (Build 200707031200)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo