Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 100199 - Cannot assign value to ${user} macro for templates
Cannot assign value to ${user} macro for templates
Status: RESOLVED DUPLICATE of bug 107725
Product: platform
Classification: Unclassified
Component: Data Systems
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-06 11:05 UTC by tkellerer
Modified: 2008-12-22 11:35 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tkellerer 2007-04-06 11:05:26 UTC
In NB 5.5 one could assign a value to the ${user} macro that is used in
Templates (Tools->Template Manager). This was available in the advanced options
under "Java sources". 

This node is now gone in NB 6.0 and I cannot find any property to define the
name used for the ${user} macro.
Comment 1 novakm 2007-04-10 10:49:59 UTC
Reassigning to Editor - Options for evaluation.
Comment 2 Vitezslav Stejskal 2007-04-10 12:12:02 UTC
There have been some changes in the way how templates are implemented in Nb6 and
perhaps this was somehow addressed by the new framework. I don't have the IZ #
handy, but it's java anyway.
Comment 3 Jan Pokorsky 2007-04-10 13:09:57 UTC
Right, java templates were migrated to the new scripting support. I cannot agree
it relates to java.

Nowadays the ${user} is supplied by the openide/loaders module that reads it
from the system property user.name. So using -J-Duser.name=YourName is the only
way to customize it AFAIK.

I am not aware of any plans for template attributes UI. Reassigning to openide
that exports the attribute.
Comment 4 Jaroslav Tulach 2007-07-09 16:21:33 UTC

*** This issue has been marked as a duplicate of 107725 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo