Bug 100079 - problem with html file with embedded js
problem with html file with embedded js
Status: RESOLVED DUPLICATE of bug 98807
Product: web
Classification: Unclassified
Component: HTML Editor
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Marek Fukala
Jindrich Sedek
EMBEDDING
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-05 10:27 UTC by Lukasz Grela
Modified: 2009-05-18 10:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
html document (936 bytes, application/octet-stream)
2007-04-05 10:38 UTC, Lukasz Grela
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukasz Grela 2007-04-05 10:27:32 UTC
during editing html files with embedded js npe exception is thrown and the html
document is only partialy displaying (some part of document are not visible).it
doesn't allow to continue work.
Comment 1 Lukasz Grela 2007-04-05 10:30:08 UTC
navigator doesn't work - only label "Parsing" is displayed
Comment 2 Lukasz Grela 2007-04-05 10:35:45 UTC
this npe is well known exception starting with:
at org.netbeans.lib.lexer.token.AbstractToken.charAt(AbstractToken.java:195)
it seems that to reproduce a html document should have some specific content so
I will attach a html file to reproduce all these bugs .
Comment 3 Lukasz Grela 2007-04-05 10:38:17 UTC
Created attachment 40493 [details]
html document
Comment 4 Marek Fukala 2007-04-05 11:48:12 UTC

*** This issue has been marked as a duplicate of 98807 ***
Comment 5 Lukasz Grela 2007-04-05 12:00:27 UTC
yes I know, but this bug is not only that exception is thrown, but during
editing you loosing the content and navigator doesn't work, and it can even
froze the ide, I mentioned about this exception just because this problem
somehow can refers to that exception.
Comment 6 Marek Fukala 2007-04-05 12:10:29 UTC
And no more exceptions? Strange... Cannot it be a duplicate or at least related
to of issue #100007? Hanz has just fix it and I am going to check. Could you do
it as well please?

> ... and it can even froze the ide, ...
Any threaddump????
Comment 7 Lukasz Grela 2007-04-05 15:31:22 UTC
IDE just froze for several second not hangs so that is why I did't make any
threaddump.
Comment 8 Marek Fukala 2007-04-05 17:14:18 UTC
OK, I see. It is still usefull to make a few threaddumps during the CPU load. It
will help to identity what is going on. I know, schliemann parser is quite slow,
especially first document opening is very slow. Please fill these issues
separately if it is possible. Unfortunatelly issue #100007 is not really fixed,
I  had to reopen, so we cannot verify if the fix will help for this issue as
well. :-(


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo