Bug 9878

Summary: attaching to a process running jpda in server mode breaks debugger
Product: debugger Reporter: Henry Story <hstory>
Component: JavaAssignee: issues <issues.netbeans.org>
Status: CLOSED INVALID QA Contact: issues <issues.netbeans.org>
Priority: P1 CC:
Version: 3.x   
Target Milestone: TBD   
Hardware: Other   
OS: Linux   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description Henry Story 2001-02-27 23:31:43 UTC
Hi, I tried attaching to an enhydra process which I had started with the 
following command line options:
"-debug -java-arg 
-Xrunjdwp:transport=dt_socket,address=7005,server=y,suspend=y"
(The enhydra script adds all the other necessary debugger option as specified 
in the jpda documentation).

As I understand this, enhdra should stop immediately on startup and wait for 
the debugger to connect. When the debugger does connect, in the latest dev 
releases, the editor display breaks up, and it shows many cursor location 
flashing all over. 

I was not able to get this to work even with the last stable netbeans release.

(http://www.enhydra.org)
Comment 1 Henry Story 2001-02-27 23:46:03 UTC
I forgot to mention that I tried both jdk1.3 from blackdown and from sun, as 
well as the jdk1.3.1 beta from sun.
Comment 2 Henry Story 2001-02-28 00:54:32 UTC
I tried the same thing on a 1 class program. In this case after I attach to 
the process with the debugger nothing happens. If I then look at the debugger 
window, and try to see what is happening to the threads, the debugger 
(netbeans) freezes. It unfreezes as soon as I kill the process it was 
attempting to attach to.

bash>java -Xdebug -Xnoagent -Djava.compiler=NONE 
-Xrunjdwp:transport=dt_socket,address=7005,server=y,suspend=y 
tools.util.http.Get http://www.google.com

I found that the problem with the editor described in the original message of 
this thread, persisted even when I was not debugging. I have cleaned up my 
setup and am starting from scratch. Perhaps this was related to moving from 
dev build 132 to 134...  

Comment 3 Jan Stola 2001-03-01 08:53:59 UTC
JDK 1.3 and 1.3.1 have problems with debugging on Hotspot VM and that
is the problem you encounter. I was able to reproduce what you
described when launching the debuggee in Hotspot VM. When I was
launching it in Classic VM everything works fine.
So, add -classic to your command line:
java -classic -Xdebug <the rest of commnad line>.
Comment 4 Jan Stola 2001-03-01 08:54:33 UTC
Invalid -> closed.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo