Bug 97882

Summary: Can't start NetBeans on Solaris x64|Sparc with JDK 1.6.0_01
Product: platform Reporter: Alexander Kouznetsov <mrkam>
Component: -- Other --Assignee: issues <issues.netbeans.org>
Status: VERIFIED WONTFIX QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: anebuzelsky, mmirilovic, pchytil, rkubacki, ttran
Version: 6.xKeywords: GTK
Target Milestone: 6.x   
Hardware: PC   
OS: Solaris   
URL: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6550660
Whiteboard: jdk_bug_6550660
Issue Type: DEFECT Exception Report:
Attachments: Dump
Messages.log
Dump

Description Alexander Kouznetsov 2007-03-14 18:05:30 UTC
NetBeans IDE Dev (Build 200703131900)
1.6.0_01-ea-b03; Java HotSpot(TM) Server VM (build 1.6.0_01-ea-b03, mixed mode)
SunOS version 5.10 running on x86
en (nb); ISO646-US

Failed to start NetBeans, get the following error during Loading Modules stage.

#
# An unexpected error has been detected by Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0xe67ff5ab, pid=8590, tid=18
#
# Java VM: Java HotSpot(TM) Server VM (1.6.0_01-ea-b03 mixed mode)
# Problematic frame:
# C  [libfontconfig.so.1+0x1f5ab]  FcFontRenderPrepare+0x73
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#
Comment 1 Alexander Kouznetsov 2007-03-14 18:06:03 UTC
Created attachment 39483 [details]
Dump
Comment 2 Alexander Kouznetsov 2007-03-14 18:06:47 UTC
Created attachment 39484 [details]
Messages.log
Comment 3 Marian Mirilovic 2007-03-19 09:30:50 UTC
Have you tried to run another Java application ?

BTW: I don't think we could do anything here ;(
Comment 4 Alexander Kouznetsov 2007-03-19 11:52:53 UTC
Yes, I've successfully run a simple J2SE java application (Anagram Game).
Comment 5 Marian Mirilovic 2007-03-22 10:05:41 UTC
reported to JDK team :
(Review ID: 930088) - Can't start NetBeans on Solaris x64 with JDK 1.6.0_01
Comment 6 _ rkubacki 2007-03-27 22:00:56 UTC
The crash is result of calls to initialize GTK libs.
Comment 7 Antonin Nebuzelsky 2007-04-02 12:49:28 UTC
Want to close as WONTFIX with a link to JDK bug?
Comment 8 Marian Mirilovic 2007-04-24 12:31:16 UTC
Petr,
please look at this. We need to be sure whether IDE runs on Sol10/x86 with JDK
6.0_01.
Thanks in advance.
Comment 9 Petr Chytil 2007-04-25 10:41:57 UTC
I was unable to reproduce it on this configuration:

NetBeans IDE Dev (Build 200704241800)
1.6.0_01; Java HotSpot(TM) Client VM 1.6.0_01-b06
SunOS version 5.10 running on x86
en (nb); ISO646-US
Comment 10 Petr Blaha 2007-04-25 16:17:14 UTC
Please, can you close a bug or mark as WONTFIX? Thanks
Comment 11 Marian Mirilovic 2007-04-25 16:29:11 UTC
mrkam,
you were using AMD Athlon(tm) 64 X2 Dual Core Processor, weren't you ?
We don't have such HW, could you please try the FCS build of jdk & if there is
still the problem, please report it directly to JDK team.

I am closing this issue as WOTNFIX, but if this is really problem, we could turn
off GTK on such OS/platform. So please let us know (at least JDK bug number).
Thanks in advance.
Comment 12 Alexander Kouznetsov 2007-04-25 19:00:33 UTC
The issue is still reproducible with the following config:

  Product Version         = NetBeans IDE Dev (Build 070425)
  Operating System        = SunOS version 5.10 running on x86
  Java; VM; Vendor; Home  = 1.6.0_01; Java HotSpot(TM) Server VM 1.6.0_01-b06;
Sun Microsystems Inc.; /opt/jdk1.6.0_01/jre
  System Locale; Encoding = en (nb); ISO646-US

The result is still the same:

Fontconfig error: Cannot load default config file
#
# An unexpected error has been detected by Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0xe626f5ab, pid=22155, tid=18
#
# Java VM: Java HotSpot(TM) Server VM (1.6.0_01-b06 mixed mode)
# Problematic frame:
# C  [libfontconfig.so.1+0x1f5ab]  FcFontRenderPrepare+0x73
#
# An error report file with more information is saved as hs_err_pid22155.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#
22155 Abort - core dumped

Looking for a way to report about this issue directly to JDK team.
Comment 13 Alexander Kouznetsov 2007-04-25 19:47:59 UTC
Created attachment 41659 [details]
Dump
Comment 14 Antonin Nebuzelsky 2007-04-26 13:39:17 UTC
Mrkam, what HW exactly do you have? Mmirilovic suspects it is AMD Athlon(tm) 64
X2 Dual Core.

Can you try starting with the following option?

  -laf javax.swing.plaf.metal.MetalLookAndFeel
Comment 15 Alexander Kouznetsov 2007-04-26 13:57:17 UTC
Dual Core AMD Opteron(tm) 2412 MHz, Ultra 20 Workstation

Netbeans has been successfully started using the option you specified.
Comment 16 Alexander Kouznetsov 2007-04-26 14:51:10 UTC
CR 6550660 filed
Comment 17 Marian Mirilovic 2007-04-26 15:11:10 UTC
mrkam, thank you very much.
Comment 18 Petr Chytil 2007-05-09 10:38:37 UTC
We managed to reproduce it on NB dev, JDK 1.6.0_01 running on Sun Blade 1000
(Sparc):

...

System Info: 
 Product Version         = NetBeans IDE Dev (Build 200705081800)
 Operating System        = SunOS version 5.10 running on sparc
 Java; VM; Vendor; Home  = 1.6.0_01; Java HotSpot(TM) Client VM 1.6.0_01-b06;
Sun Microsystems Inc.; /space/jdks/jdk1.6.0_01/jre
 System Locale; Encoding = en_GB (nb); UTF-8

...

[ideTestRunner] # An unexpected error has been detected by Java Runtime Environment:
[ideTestRunner] #
[ideTestRunner] #  SIGSEGV (0xb) at pc=0xf9841b7c, pid=20218, tid=14
[ideTestRunner] #
[ideTestRunner] # Java VM: Java HotSpot(TM) Client VM (1.6.0_01-b06 mixed mode,
sharing)
[ideTestRunner] # Problematic frame:
[ideTestRunner] # C  [libfontconfig.so.1+0x21b7c]  FcFontSetMatch+0xc4c
[ideTestRunner] #
[ideTestRunner] # An error report file with more information is saved as
hs_err_pid20218.log
[ideTestRunner] #
[ideTestRunner] # If you would like to submit a bug report, please visit:
[ideTestRunner] #   http://java.sun.com/webapps/bugreport/crash.jsp
[ideTestRunner] #
[ideTestRunner] my pid = 20218
[ideTestRunner] 20218 Abort - core dumped
[ideTestRunner] Result: 134
Comment 19 Petr Chytil 2007-05-11 09:30:38 UTC
And we've found solution for this situation in nbusers mailing list. 

Two patches for Solaris 10 on Sparc led to the solution:
120473 and 125100-04 (or greater)

There are also comparable patches for x86 machines running Solaris 10. Applying
this one should be sufficient:
120037

IDE runs normally after applying these patches.
Comment 20 Alexander Kouznetsov 2007-05-31 17:41:52 UTC
I have 120037-09 and 120037-13 patches installed on my Solaris 10 (from the
original description), but the bug is still reproducible. Moreover, there are no
more patches or updates available according to Solaris Update Manager.

What else needs to be done to deal with this issue?
Comment 21 Alexander Kouznetsov 2007-06-05 13:47:24 UTC
120037-15 patch solves the problem. However it is not released yet.
Comment 22 Marian Mirilovic 2007-06-18 09:14:55 UTC
*** Issue 106950 has been marked as a duplicate of this issue. ***
Comment 23 David Simonek 2007-06-19 11:35:49 UTC
Metal L&F forced on Solaris 10 as workaround:

Checking in Startup.java;
/cvs/core/swing/plaf/src/org/netbeans/swing/plaf/Startup.java,v  <--  Startup.java
new revision: 1.30; previous revision: 1.29
done

rkubacki please test on Solaris 11 that it still loads GTK, just to be sure. I tested on Solaris 10 to verify Metal is
loaded instead of GTK.
Comment 24 Alexander Kouznetsov 2007-06-20 09:26:35 UTC
120037-15 patch has been released.
Comment 25 Tomas Danek 2007-06-22 12:57:17 UTC
I've tester that latest bits of netbeans sucessfully start on following config:

Product Version: NetBeans IDE Dev (Build 200706211800, C/C++ Pack 20070621) Java: 1.6.0_01; Java HotSpot(TM) Client VM
1.6.0_01-b06 System: SunOS version 5.10 running on x86; UTF-8; cs_CZ (nb) Userdir: /tmp/ud
Comment 26 Petr Chytil 2007-07-02 16:10:26 UTC
I've updated my Solaris 10 x64 installation with latest updates and now everything seems to be working. I've tested it
on two different build with following results:

1)
NetBeans IDE Dev (Build 200703280911)
1.6.0_01; Java HotSpot(TM) Client VM 1.6.0_01-b06
SunOS version 5.10 running on x86
cs_CZ (nb); UTF-8

OK, IDE uses GTK

2)
Product Version: NetBeans IDE Dev (Build 200707020000) 
Java: 1.6.0_01; Java HotSpot(TM) Client VM 1.6.0_01-b06 
System: SunOS version 5.10 running on x86; UTF-8; cs_CZ (nb) Userdir: /home/tester/.netbeans/dev

OK, IDE uses Metal
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo