Bug 92009

Summary: JSF pages from Entity class functionality missing
Product: javaee Reporter: Jaroslav Pospisil <jpospisil>
Component: JSFAssignee: _ potingwu <potingwu>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: bleonard, emononen, jskrivanek, pjiricka, vadirajvd, ymhsenger
Version: 6.xKeywords: REGRESSION
Target Milestone: 6.x   
Hardware: All   
OS: Windows ME/2000   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:
Bug Depends on:    
Bug Blocks: 88829, 92999    

Description Jaroslav Pospisil 2007-01-08 12:46:17 UTC
JSF pages from Entity class functionality is missing. It's disabled due to
retouche merge and should be working before FF.
Comment 1 Petr Pisl 2007-02-06 09:05:16 UTC
This functionality needs to be rewritten from scratch due to Retouche. So I
don't expect that this will be sooner then in M8. 
Comment 2 Jan Horvath 2007-06-18 12:17:10 UTC
This feature is dropped in 6.0
Comment 3 martin_adamek 2007-06-18 13:08:13 UTC
*** Issue 98869 has been marked as a duplicate of this issue. ***
Comment 4 Joseph Silber 2007-09-10 12:55:28 UTC
Release note added
Comment 5 wiik 2007-10-23 22:11:47 UTC
Is there a reason why to drop this important feature?
Comment 6 wiik 2007-10-23 22:12:32 UTC
Is there a reason why to drop this important feature?
Comment 7 Petr Jiricka 2007-10-24 00:32:02 UTC
The reason is that there was not enough time to port this feature over to the new Java development infrastructure in the
6.0 release. The old code from NetBeans 5.5 does not work with NetBeans 6. If we wanted to add this to NetBeans 6, we
would have to extend the 6.0 schedule by another couple months. 
Comment 8 William Leonard 2007-10-24 02:06:26 UTC
But as regression from NetBeans 5.5 (and a major one), it shouldn't be marked as a FEATURE. I'll leave it up to your
discretion Peter, but I disagree with the assessment.

/Brian
Comment 9 Roman Strobl 2007-10-24 12:53:45 UTC
Increasing priority to P1. The lack of this feature forces me to demo Visual Web Pack, because I can't show anything
quickly using JSF with manual editing. About 30 different people complained to me so far about this regression, of
course mainly evangelists. 
Comment 10 Erno Mononen 2007-10-24 13:52:14 UTC
> But as regression from NetBeans 5.5 (and a major one), it shouldn't be marked as a FEATURE. I'll leave it up to your
> discretion Peter, but I disagree with the assessment.
>
> /Brian

I have to disagree with having defects for dropped features. We also don't have an open defect for not being able to 
run the IDE on JDK 1.3 even though it used be possible. Dropping any feature can always be seen as a regression, but if 
there has been a deliberate decision to be drop a certain feature, I don't see the point in having open defects for it 
- it wouldn't be any different from having defects for non-existing features.
Comment 11 William Leonard 2007-10-24 17:47:55 UTC
Erno, I wasn't aware this feature was dropped - just postponed past 6.0 (hopefully 6.1). And you can't compare JDK 1.3
(dead or dying) to JSF (growing and an important technology to Sun). Don't underestimate the popularity and usefulness
of this feature (beyond just demos). It's very difficult to even find an article on using JPA with NetBeans that doesn't
also refer to this feature. At the moment, there are no articles on JPA with NetBeans 6.0.

/Brian
Comment 12 Erno Mononen 2007-10-25 09:36:47 UTC
Hi Brian,
my point wasn't to compare JDK 1.3 with JSF in terms of their usefulness/popularity/future prospects, it was just an 
example of a dropped feature - if we were to reintroduce support for JDK 1.3, I think it would rather be an enhancement/
feature than a defect. I understand that this feature (i.e. JSF from entities) is important for many people and 
personally I'm not against bringing it back. That said, I don't think that the importance of JSF is by any means 
currently underestimated in NetBeans - in fact, you could argue the opposite (given that we don't have any support for 
some of the more popular frameworks/technologies out there).
Comment 13 Petr Jiricka 2007-10-25 13:18:04 UTC
The option to bring the festure back in NetBeans 6.x is very much on the table; if we decide to do it, then the
resulting application it generates should be compatible with Visual Web features.
Comment 14 emarin 2007-11-27 21:40:21 UTC
Muy importante para mi, es sumamente util
Comment 15 _ tboudreau 2007-12-21 01:18:16 UTC
Note that we are getting feedback from users of NetBeans that they were quite angry that this feature was removed - it is not just demoware - real people are 
using it.  C.f. Brian's recent trip reports from Javapolis - perhaps he can attach some of the feedback.
Comment 16 William Leonard 2007-12-21 16:20:13 UTC
Sure, here's the note from my JavaPolis trip report...

Lots of dismay over the missing JSF Pages from Entity Class feature. As one developer told me "I'm sorry, but we used
many impolite words when we found that feature missing." Yara Senger (Dream Teamer Vinicius' wife) didn't realize it was
missing until the middle of her JSF presentation, during which she had to revert to 5.5.

Comment 17 martin_adamek 2007-12-21 17:33:36 UTC
... and still no real use-case for it
Comment 18 William Leonard 2007-12-21 21:28:05 UTC
Martin, there are very real use-cases for this feature. Getting a skeleton JSF application up and running against MY
data is invaluable. I have spoken to numerous DEVELOPERS that miss this feature greatly. I have added Yara Senger,
founder a Globalcode in Brazil to the Cc. Yara, being a real developer (and not just an evangelist like myself), please
feel free to  add any additional information in support of this feature. /Brian
Comment 19 ymhsenger 2008-01-09 22:14:46 UTC
What I really like in that feature is that the generated code shows a nice way of using JPA with JSF, besides the
creation of converters and validators for our "real world" needs. Even when you are not going to use the generated code
on your final application it stills valuable since it builds everything over your entities making easier to learn and
understand.

I beleive that one of the best advantages NetBeans have over any other IDE is the way it delivers educational content:
with comments inside JSPs, with the Design Patterns tool, with Blue Prints catalog as a built in project, and many other
situations.

Another wonderful thing is that it doesn't uses Component binding for every component in the JSP pages like Visual Web
Pack does! But I'm very happy that this is being considered in the issue 123536. 

Thank you Brian for motivating me on this participation and thank you all for making Netbeans 5.5 and 6.0 so good.



Comment 20 _ alexstevenson 2008-01-24 16:48:28 UTC
My small company has developed a practice, based upon NetBeans 5.5, for creating a software functional prototype which 
aims to make the fullest use of the code generation features. Two features of central interest are: generation of 
database tables from the repesentation in Entity Classes of the application's domain data model; generation of an 
application's View and Controller components using 'JSF Pages from Entity classes'. NetBeans 6 appears to offer further 
advantages re the 'agile' objectives of our practice so the hope here is that the feature will not be too long delayed. 
Comment 21 _ potingwu 2008-03-13 18:26:57 UTC
"JSF pages from Entity class functionality" is back in NetBeans 6.1.
Comment 22 William Leonard 2008-03-25 20:33:37 UTC
But it's still not working for me (at least in the Beta). I still have these issues:

1) index.jsp is missing the taglib declarations, so the <h:commandLink ...> throws an error.
2) If the controllers are put into a different package then the entity classes, the entity classes are missing their
import statements.
3) After fixing those issues, the application fails to run with a RuntimeException: cannot find FacesContext.
Comment 23 _ potingwu 2008-03-25 21:51:25 UTC
Please file individual bug for 'issue'. This one is for the 'feature'. Thanks!
Comment 24 Jaroslav Pospisil 2008-04-03 14:58:02 UTC
v.
Comment 25 mero 2008-05-23 07:14:47 UTC
if we are working now on netbean 6 and we need to use this feature jsf from entity class does this mean we have to install 
version 6.1 comm on this is not good solution for me am wokring on my graduation project here people! please if there is
any plug in we can add that would solve the problem
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo