Bug 9044

Summary: Add watch action is not enabled.
Product: debugger Reporter: Jan Stola <jstola>
Component: CodeAssignee: issues <issues.netbeans.org>
Status: CLOSED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: jglick
Version: 3.x   
Target Milestone: TBD   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:
Bug Depends on: 9287    
Bug Blocks:    

Description Jan Stola 2001-01-09 12:33:10 UTC
Pilsen (build 010106) and Netbeans (build 99)
---------------------------------------------

Steps to reproduce :-)
1. Start IDE.
2. Look if the add watch action is enabled.
Comment 1 Jesse Glick 2001-01-30 15:52:59 UTC
Ultimately a bug in SharedClassObject, I think.
Comment 2 Jesse Glick 2001-01-30 17:44:59 UTC
I cannot reproduce this in jan 30 dev sources. Add Watch is enabled. Under what
conditions does this appear?

(Linked to #9287 based on message to dev@openide from Jan Lahoda, I think.)
Comment 3 Daniel Prusa 2001-01-31 12:40:59 UTC
It can be reproduced in Netbeans, build 114. The AddWatch action is disabled in
Debug Toolbar and in Debug menu too. The only way how to add a watch is using
context menu invoked on a source in Editor.
Comment 4 Jesse Glick 2001-01-31 13:34:59 UTC
Got it. It is enabled the first time you start up; disabled after having
restarted the IDE, for whatever reason.
Comment 5 Jan Stola 2001-02-13 10:38:59 UTC
Fix of bug #9287 is fix of this bug, too.
Comment 6 Jan Stola 2001-02-13 10:39:59 UTC
Verified in Pilsen (build 010212_1) and Netbeans (build 125).
Comment 7 Quality Engineering 2003-06-30 17:26:22 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo