Bug 8843

Summary: debugger hangs on dual processor
Product: debugger Reporter: patrice <patrice>
Component: CodeAssignee: issues <issues.netbeans.org>
Status: CLOSED WONTFIX QA Contact: issues <issues.netbeans.org>
Priority: P1 CC:
Version: -FFJ-   
Target Milestone: TBD   
Hardware: PC   
OS: Other   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: thread dump
forte4j log file
thread dump 2
thread dump 3

Description patrice 2000-12-08 20:21:43 UTC
I am using Forte for Java CE on two machines, one a dual processor the other a
single processor.  On the dual processor machine the debugger seems to "take
off" doing something (I don't know what) and my program does not execute beyond
the first few lines of code (it won't ever hit breakpoints I have set near the
beginning of the program).  If I don't wait too long, I can use the
Debug/Finish Debugging menu item to kill the process.  If I wait too long then
I can't get to that menu (the IDE is not able to get the window events) and I
need to kill the java process using the Windows Task Manager.

This problem is intermittent although it occurs more often than not, making
doing debugging work on the dual processor machine infeasible.  I don't always
lose control at the same spot (although if I am going to lose control on any
given execution it always occurs early).  It does not occur outside the IDE nor
have I seen it occur yet executing within the IDE without the debugger.  It
does not occur on the single processor machine.

Are there known problems with running the debugger on dual processor machines?
Comment 1 Daniel Prusa 2000-12-19 16:16:59 UTC
There have already been complains about debugging on dual processor. But I am
not able to reproduce this problem. I have tried to debug using Linux and NT +
dual processor machine and it seemed to be OK.
Can you provide me more info, please ?
What is your platform ? Can you attach your ide.log file ?
Full thread dump can be helpfull too. (It's printed on the console after
CTRL+Break.) I am interested in thread dump of two states that you descibed:
1) after start of debugger and execution of the first few lines
2) when the whole IDE is frozen (if you wait too long)
Thanks.
Comment 2 patrice 2001-01-23 19:57:59 UTC
Created attachment 489 [details]
thread dump
Comment 3 patrice 2001-01-23 20:01:59 UTC
Created attachment 490 [details]
forte4j log file
Comment 4 patrice 2001-01-23 20:22:59 UTC
Created attachment 491 [details]
thread dump 2
Comment 5 patrice 2001-01-24 01:22:59 UTC
Created attachment 492 [details]
thread dump 3
Comment 6 Jan Stola 2001-02-08 09:18:59 UTC
I am sorry. We cannot fix that bug. It's a bug of JDK. See
http://developer.java.sun.com/developer/bugParade/bugs/4372740.html
for details.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo