Bug 77099

Summary: 'Find' doesn't work for C++/C projects
Product: cnd Reporter: Alexander Ioffe <aioffe>
Component: -- Other --Assignee: Thomas Preisler <thp>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 Keywords: USABILITY
Version: 5.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard: CND1-FCS projectsystem
Issue Type: DEFECT Exception Report:

Description Alexander Ioffe 2006-05-30 16:58:08 UTC
Create C++ project (f.e. get the sample one 'helloapp')
Invoke popup menu for the project in project view and choose "Find'
type i in string to find, choose OK.
No matches found.
Neither "Find text" nor "Find object" work.
Comment 1 Andrew Krasny 2006-10-19 09:43:43 UTC
There were a lot of complains from those who participated in blitz and
bug-a-thon about lack of this feature. 
This is a big usability issue.
Comment 2 Thomas Preisler 2006-10-19 18:37:44 UTC
*** Issue 84471 has been marked as a duplicate of this issue. ***
Comment 3 Thomas Preisler 2006-10-24 21:42:08 UTC
Fixed. Find works as expected by seraching files in the project by recursively
going down into sub folders from the folder the search is initiated rom.

Find In Projects has some limitations though with C/C++ projects because of the
nature of these projects. C/C++ projects don't have source roots whic the Find
In Projects action expects. This means searching a C/C++ project using Find In
Projects will not look outside the project and it will search all files
underneath project root. See IZ 64392.

NetBeans' Replace action is limited to one source files and don't go across
several files or a project. What we need is a simple refactor feature that can
replace Replace.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo