Bug 75114

Summary: "code folding" in C files are disabled
Product: cnd Reporter: soldatov <soldatov>
Component: EditorAssignee: issues <issues.netbeans.org>
Status: VERIFIED WORKSFORME QA Contact: issues <issues.netbeans.org>
Priority: P1 CC:
Version: 6.x   
Target Milestone: 6.x   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description soldatov 2006-04-17 10:23:36 UTC
Steps:
- Push File|New Project... menu.
- Choose "Samples|C/C++ Development|C/C++|Args" project. Push "Next" button.
- Push "Finish" button.
- Open args.c file in built-in editor.

"code folding" in C files are disabled
Comment 1 _ gordonp 2006-04-17 16:30:51 UTC
Please reverify this problem against a build from 17 April or later. I checked
in a fix for 74332 last Friday which should have resoled this. I just did cvs
updates and builds on both my Solaris box and laptop and both correctly showed
both the code folding and syntax highlighting.

I believe 74332 was the cause of the problem you reported here, because it
was caused by incorrect mime-type for C files. Because the editor didn't get
the correct mime-type, it didn't use the advanced editing features for C (which
includes code completion).

Please reverify and reopen the bug if you still see the problem.
Comment 2 akumta 2007-12-20 18:00:07 UTC
Verified on Solaris, Windows and Linux.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo