Bug 74541

Summary: Makefile indentation is wrong
Product: cnd Reporter: _ gordonp <gordonp>
Component: -- Other --Assignee: _ gordonp <gordonp>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1    
Version: 5.x   
Target Milestone: TBD   
Hardware: All   
OS: All   
Whiteboard: CND1-FCS editing
Issue Type: DEFECT Exception Report:

Description _ gordonp 2006-04-06 20:34:15 UTC
If I press <CR> from the end of a target line I should automatically get a
tab indentation. The indentation engine should also never substitute spaces
for tabs (in Makefiles).

This may only be a NB6 issue (need to verify this). If so, downgrade to P3.
Comment 1 Thomas Preisler 2006-04-06 20:47:10 UTC
Makefiles have their own indentation engine
org.netbeans.modules.cnd.editor.makefile.MakefileIndentEngine
which sets the correct properties, but it it somehow ignored.

I can duplicate this with NB5.0.
Comment 2 Thomas Preisler 2006-10-10 17:57:21 UTC
*** Issue 86751 has been marked as a duplicate of this issue. ***
Comment 3 _ gordonp 2006-10-10 21:44:02 UTC
Added CND1-FCS since 86751 was CND1-FCS and closed as a duplicate of this
issue.
Comment 4 _ gordonp 2006-10-28 01:03:04 UTC
Fixed
Comment 5 Maria Tishkova 2007-10-31 16:06:32 UTC
verified
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo