Bug 65809

Summary: there's not possible to create DB connection
Product: db Reporter: pknakal <pknakal>
Component: CodeAssignee: Andrei Badea <abadea>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1    
Version: 5.x   
Target Milestone: 5.x   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: DEFECT Exception Report:
Attachments: DB connection error
log with error

Description pknakal 2005-10-04 09:11:17 UTC
When creating JDBC connection to Oracle DB, on DB server side using Oracle
connection mamager, an error message apears.

The connection string is something like this:
jdbc:oracle:thin:@(description=(address_list=(address=(protocol=tcp)(port=1610)(host=00.00.00.00))(address=(protocol=tcp)(port=1521)(host=00.00.00.00)))(connect_data=(SID=QQQ))(source_route=yes))

The functionality is correct in the NB4.1
Comment 1 pknakal 2005-10-04 09:12:02 UTC
Created attachment 25487 [details]
DB connection error
Comment 2 Andrei Badea 2005-10-04 10:38:05 UTC
I'm not able to reproduce. I think I understand what's happening, but not why.
Are you able to reproduce the issue from a clean userdir? If, yes, please post
steps. If not, please attach your userdir. Also when the error message appears,
there may be some messages written to the message log. If yes, post them here as
well. Thanks. 
Comment 3 pknakal 2005-10-04 11:17:21 UTC
This is 100% reproducable. The Oracle DB server is Oracle8 (not oracle 8i) and
is installed on Windows, so on this server is necessary to install connection
manager to mascarade the connection ports.

I'll attached the log with exception.
Comment 4 pknakal 2005-10-04 11:18:33 UTC
Created attachment 25495 [details]
log with error
Comment 5 Andrei Badea 2005-10-04 13:32:28 UTC
Thank you for the details. Fixed.

Checking in DatabaseConnectionConvertor.java;
/cvs/db/src/org/netbeans/modules/db/explorer/DatabaseConnectionConvertor.java,v
 <--  DatabaseConnectionConvertor.java
new revision: 1.4; previous revision: 1.3
done
Comment 6 Andrei Badea 2005-10-04 14:13:10 UTC
Fixing a small bug in the previous fix.

Checking in DatabaseConnectionConvertor.java;
/cvs/db/src/org/netbeans/modules/db/explorer/DatabaseConnectionConvertor.java,v
 <--  DatabaseConnectionConvertor.java
new revision: 1.5; previous revision: 1.4
done
Comment 7 pknakal 2005-10-11 08:59:11 UTC
OK.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo