Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 65482

Summary: [50cat] Installer doesn't work - bc: command not found
Product: installer Reporter: jcstover <jcstover>
Component: CodeAssignee: mslama <mslama>
Status: RESOLVED WONTFIX QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: jchalupa, mmirilovic
Version: 5.xKeywords: RELNOTE
Target Milestone: 5.x   
Hardware: PC   
OS: Linux   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description jcstover 2005-09-30 07:13:21 UTC
[ JDK VERSION : 1.5.0_04 ]

Using slackware 10.1, kernel 2.6.10 and jdk 1.5.0_04 
The installer gives multiple times the next error

          Initializing InstallShield Wizard........
./netbeans-5_0-beta-bin-linux.bin: line 189: bc: command not found
./netbeans-5_0-beta-bin-linux.bin: line 404: [: : integer expression expected

Using the archive as work around
Comment 1 Jan Chalupa 2005-10-02 17:31:34 UTC
Yet another report of 'bc' missing on the target system. I know IS 11 now
depends on 'bc'. However, there seems to be many Linux installations that don't
install 'bc' by default. Do we have an option of using something else with IS
11? If not, can we detect the problem and provide the user with a better
warning? In the worst case, we'll need to release note this as a known issue.
Comment 2 Marian Mirilovic 2005-10-02 17:42:00 UTC
Agreed with RN.
Also rising priority, just to be sure, it will be solved for NB 5.0 (at least
evaluated).
Comment 3 mslama 2005-10-03 07:59:37 UTC
It is known problem of Install Shield. See
http://support.installshield.com/kb/view.asp?articleid=Q110974. The refer to
Mandrake. Slackware is apparently another Linux distribution with this problem.
The only possible solution for would be to modify installer startup script not
to use bc. (It is used just to convert hexadecimal number to decimal.)
Comment 4 Jan Chalupa 2005-10-11 15:43:58 UTC
The problem has been documented in the Troubleshooting section of the
Installation Guide for NB 5.0. There's not much we can do to work around this
InstallShield issue. -> WONTFIX.
Comment 5 Jan Chalupa 2005-11-17 08:02:36 UTC
*** Issue 68877 has been marked as a duplicate of this issue. ***
Comment 6 mslama 2007-07-26 10:49:28 UTC
Fixed for NB 6.0: New installer engine does not depend on 'bc'.
Comment 7 mslama 2007-07-26 10:49:29 UTC
*** Issue 108105 has been marked as a duplicate of this issue. ***
Comment 8 mslama 2007-07-26 10:50:23 UTC
*** Issue 72267 has been marked as a duplicate of this issue. ***
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo