Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 62062

Summary: Keyboard lockes while using IDE
Product: editor Reporter: Tomas Danek <musilt2>
Component: -- Other --Assignee: issues <issues.netbeans.org>
Status: VERIFIED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P3    
Version: 5.x   
Target Milestone: 5.x   
Hardware: Macintosh   
OS: Mac OS X   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description Tomas Danek 2005-08-10 15:47:21 UTC
Sometimes, when using NB for a long time, keyboard gets locked. i.e. im working
in editor, an suddenly, cursor dissapears, typing letters does nothing,shortcuts
son't work,... switching windows inside IDE does not help, nor clicking mouse
anywhere inside the editor.  I have to switch to another application and then
swich back to IDE to unlock. Probably hard to reproduce and even harder to fix,
just reporting if someone notices it too and has some steps to reproduce.
Comment 1 Milos Kleint 2005-08-11 08:23:23 UTC
are you doing find sometime before the locking happens?

I think it's a duplicate of a known issue in editor.. reassigning for evaluation
Comment 2 Tomas Danek 2005-08-11 08:55:52 UTC
I'm not quite sure, but it probably i used Find. If this issue is already filed,
feel free to mark it as duplicate.
Comment 3 Tomas Danek 2005-08-11 11:13:46 UTC
..and today with the same build WITHOUT using Find!! 
Comment 4 dimaulupov 2005-09-06 13:14:31 UTC
The same situation in MacOSX(10.4.2)

At random times keyboard locks up.

I've upgraded to last Q-Build (200508231315) and problem remains.

At the same time with keabord lock up another problem raises you can not change files (in editor 
window) with menu at the top-right corner of the window.
You can open menu, click on a file but nothing happens.

Sorry, but I don't have any idea how to reproduce this...

On Mac you can't regain control of a keyboard with switching to other windows (as musilt2 says) there 
is another way.

You have to open Preferences, close it and keyboard is back. 
Comment 5 dimaulupov 2005-09-06 14:56:31 UTC
I've found a way to reproduce this bug on a MacOSX!

NetBeans Q-Build (200508231315)

java -version
java version "1.5.0_02"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_02-56)
Java HotSpot(TM) Client VM (build 1.5.0_02-36, mixed mode, sharing)

1) Open NetBeans
2) Go to File -> New Project.
3) Choose Project "General -> Java Application"
4) Default path, "create a main class" - checked.
5) Click Finish.
6) NetBeans will create a new project, and will open file "Main.java".
7) Click with a mouse to upper-right corner of the editor window to open drop-down list of opened 
files. 
8) Click on "Main.java" (actually any other file)
9) Keyboard is gone. You can't type anything in the editor window.
Comment 6 dimaulupov 2005-09-07 10:57:07 UTC
And one more way to reproduce this bug.

Mac OSX (10.4.2)

java version "1.5.0_02"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_02-56)
Java HotSpot(TM) Client VM (build 1.5.0_02-36, mixed mode, sharing)

1) Make New Project of type Java Application with a main class.
2) Netbeans will open Main.java to edit.
3) Inside Main class make a new line "ArrayList myList;", leave typing cursor at the end of the line.
4) Wait for red underline appears and little bulb at the left side.
5) Click on that little bulb.
6) One item menu appears with "Add import for java.util.ArrayList" text.
7) Click on it.
8) Keyboard locks. You can't type anything.
Comment 7 dimaulupov 2005-09-07 10:57:59 UTC
I think for someone to notice this bug it's good to remove "RANDOM" keyword from it.
Comment 8 Tomas Danek 2005-09-07 15:50:46 UTC
I was not able to reproduce on JDK 1.5.0_03, IDE 20050905 on WIN XP:( This is
quite annoying... changing to mac platform..
Milosi, please try steps to reprocuce on MAC..
Comment 9 Martin Matula 2005-09-11 12:52:02 UTC

*** This issue has been marked as a duplicate of 60235 ***
Comment 10 Tomas Danek 2005-09-12 11:52:14 UTC
yes, it seems to be a duplicate.. but added link, to save these useful comments.
Verified as dup.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo