Bug 61551

Summary: Spaces not supported in pathnames used in NBM module development
Product: apisupport Reporter: rmatous <rmatous>
Component: HarnessAssignee: Jesse Glick <jglick>
Status: CLOSED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: jchalupa, mmirilovic
Version: 5.xKeywords: SPACE_IN_PATH
Target Milestone: 5.x   
Hardware: All   
OS: Windows XP   
Whiteboard:
Issue Type: DEFECT Exception Report:
Bug Depends on: 68373    
Bug Blocks:    
Attachments: snippers of ide.log
Minimal patch for the beta branch
Trying again

Description rmatous 2005-07-29 16:43:26 UTC
Generating standalone module into HomeDir containing spaces in name like
C:\Documents and Settings\.. causes problems after Install/Reload in Target
Platform because IDE is started with wrong UserDir. See attachments.
Comment 1 rmatous 2005-07-29 16:49:16 UTC
Created attachment 23368 [details]
snippers of ide.log
Comment 2 Jesse Glick 2005-09-06 19:10:00 UTC
*** Issue 63578 has been marked as a duplicate of this issue. ***
Comment 3 Tomas Danek 2005-09-07 13:02:03 UTC
It causes even much more worse problems, it makes platform unusable, when not
noticing this.. see duplicate issue 63578
Comment 4 pzajac 2005-09-20 14:48:06 UTC
The default folder in new project wizard is in "C:\Documents and Settings"
because there are user acounts.  So we can expect that user will create his
first  netbeans module in this location. Jesse, can you fix it for beta? 

Comment 5 Tomas Danek 2005-09-20 14:55:08 UTC
I'm considering to rise this to P1 - scenariO: 
1) user creates a sample module project - feedreeder
2) since user's "so called" home on Win is C:\Documents and Settings\.., it's
highly probable that (s)he installs it right here
3) user tries to run this sample : bare platform is launched, after closing it,
user's buried under pile of exceptions..

question follows - will you take a look at this soon??
Comment 6 Jesse Glick 2005-09-21 02:58:50 UTC
Have fix.
Comment 7 Jesse Glick 2005-09-21 05:18:45 UTC
Hopefully will work now - tested on Linux.

committed   * Up-To-Date  1.6         apisupport/harness/release/build.xml
committed   * Up-To-Date  1.16        apisupport/harness/release/jnlp.xml
committed   * Up-To-Date  1.7         apisupport/harness/release/run.xml
committed   * Up-To-Date  1.4         apisupport/harness/release/etc/app.conf
committed   * Up-To-Date  1.3         apisupport/harness/release/launchers/app.sh
committed   * Up-To-Date  1.17        nbbuild/templates/common.xml
Comment 8 Tomas Danek 2005-09-21 12:42:54 UTC
*** Issue 64788 has been marked as a duplicate of this issue. ***
Comment 9 Jesse Glick 2005-09-21 21:45:42 UTC
Possible beta candidate?
Comment 10 pzajac 2005-09-22 10:17:37 UTC
I am for to add it to beta. 
Comment 11 Marian Mirilovic 2005-09-22 10:22:53 UTC
Petr are you sure? 
If so, please increase the priority, test it in the trunk and ask Radek to merge
the fix to beta branch.
Comment 12 Tomas Danek 2005-09-22 14:56:52 UTC
To me seems to be the fix ok! Petre?
Comment 13 pzajac 2005-09-22 15:48:57 UTC
Yes, it works fine in trunk.
Comment 14 Marian Mirilovic 2005-09-22 15:52:09 UTC
Ok, let's make it Beta stopper.

Jesse, 
please merge the fix to beta branch, thanks in advance.
Comment 15 Jesse Glick 2005-09-23 18:40:38 UTC
Created attachment 25122 [details]
Minimal patch for the beta branch
Comment 16 Jesse Glick 2005-09-23 19:25:00 UTC
The existing patch was actually not complete, as I find in testing it more. I
will put the full patch into the beta branch now, and the trunk soon.
Comment 17 Jesse Glick 2005-09-23 19:33:18 UTC
Most significantly, I find that the Unix launcher did not handle spaces in the
userdir at all. No idea how long this has been broken.
Comment 18 Jesse Glick 2005-09-23 19:40:30 UTC
Ghod save me from Bourne shell quoting semantics... still trying to make it
actually work...
Comment 19 Jesse Glick 2005-09-23 20:07:17 UTC
Created attachment 25126 [details]
Trying again
Comment 20 Jesse Glick 2005-09-23 20:09:08 UTC
Fixing in beta:

Checking in apisupport/harness/release/build.xml;
/cvs/apisupport/harness/release/build.xml,v  <--  build.xml
new revision: 1.5.4.1; previous revision: 1.5
done
Checking in apisupport/harness/release/jnlp.xml;
/cvs/apisupport/harness/release/jnlp.xml,v  <--  jnlp.xml
new revision: 1.15.2.2; previous revision: 1.15.2.1
done
Checking in apisupport/harness/release/run.xml;
/cvs/apisupport/harness/release/run.xml,v  <--  run.xml
new revision: 1.6.4.1; previous revision: 1.6
done
Checking in apisupport/harness/release/etc/app.conf;
/cvs/apisupport/harness/release/etc/app.conf,v  <--  app.conf
new revision: 1.3.2.1; previous revision: 1.3
done
Checking in apisupport/harness/release/launchers/app.sh;
/cvs/apisupport/harness/release/launchers/app.sh,v  <--  app.sh
new revision: 1.2.2.1; previous revision: 1.2
done
Checking in core/launcher/unix/nbexec;
/cvs/core/launcher/unix/nbexec,v  <--  nbexec
new revision: 1.24.26.1; previous revision: 1.24
done
Checking in ide/launcher/unix/netbeans;
/cvs/ide/launcher/unix/netbeans,v  <--  netbeans
new revision: 1.24.4.1; previous revision: 1.24
done

Please review & test as I had to patch the IDE's and platform's behavior, not
just apisupport.
Comment 21 Jesse Glick 2005-09-23 20:11:21 UTC
Remaining trunk fixes:

Checking in apisupport/harness/release/run.xml;
/cvs/apisupport/harness/release/run.xml,v  <--  run.xml
new revision: 1.8; previous revision: 1.7
done
Checking in apisupport/harness/release/launchers/app.sh;
/cvs/apisupport/harness/release/launchers/app.sh,v  <--  app.sh
new revision: 1.4; previous revision: 1.3
done
Checking in core/launcher/unix/nbexec;
/cvs/core/launcher/unix/nbexec,v  <--  nbexec
new revision: 1.25; previous revision: 1.24
done
Checking in ide/launcher/unix/netbeans;
/cvs/ide/launcher/unix/netbeans,v  <--  netbeans
new revision: 1.25; previous revision: 1.24
done

Please test carefully.
Comment 22 Tomas Danek 2005-09-26 13:27:19 UTC
See issue 64807. Your fix of this might have broken it?
Comment 23 Tomas Danek 2005-09-26 13:50:09 UTC
Sorry for false accusation, your fix did not affect #64807 :-)
Comment 24 Tomas Danek 2005-10-21 15:54:14 UTC
works fine now, closing.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo