Bug 56401

Summary: add support for multiple clipboards
Product: editor Reporter: seancc <seancc>
Component: -- Other --Assignee: Milutin Kristofic <mkristofic>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P1 CC: allanNB, edburns, geertjan, hmichel, softwarevisualization
Version: 6.xKeywords: PLAN
Target Milestone: 7.3   
Hardware: All   
OS: All   
See Also: https://launchpad.net/bugs/218624
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:

Description seancc 2005-03-14 19:10:00 UTC
Been using NetBeans for a year or so now and I love it.

But one thing that is sorely missing (or seems to be) is support for multiple
clipboards in the editor. I would like to be able to press CONTROL+SHIFT+V to
select which of the last 10 or so strings I've cut/copied and paste then it.
Currently NB supports pasting the last string. MS Word and most popular
programming editors I've used support multiple clipboards.
Comment 1 Vitezslav Stejskal 2007-11-05 13:31:27 UTC
Moving to the 'other' subcomponent.
Comment 2 voidmain 2008-12-05 17:39:42 UTC
I second this. Most editors and IDEs now support multiple clipboards and many developers rely on that feature for
productivity. This is one of the major blocking features for NetBeans over IDEs like IntelliJ.
Comment 3 uyuni 2009-11-25 23:43:16 UTC
I also think multiple clipboards are important. Unfortunately clipboard recorder from http://www.lw-works.com/ does not work in Netbeans. Netbeans is the only program I know where clipboard recorder is not working!
Comment 4 Mr_and_Mrs_D 2011-02-19 21:39:50 UTC
(In reply to comment #3)
> I also think multiple clipboards are important. Unfortunately clipboard
> recorder from http://www.lw-works.com/ does not work in Netbeans. Netbeans is
> the only program I know where clipboard recorder is not working!

+1 !!!
Any explanation on this ?
Maybe should be filled as a separate bug ?
Comment 5 Mr_and_Mrs_D 2011-12-25 12:37:10 UTC
Also Parcellite 1.0.2rc5 does not work with netbeans 7.0.1 on Ubuntu 11.10
Please let me know if I should fill a separate bug for it and clipboard recorder not working on windows. Any explanation ?
Comment 6 Mr_and_Mrs_D 2012-01-25 20:08:11 UTC
Very glad this is being worked on !
Thank you very much !
really this clipboard recorder and similar tools not working was a major PITA

Why would this happen by the way ?
Comment 7 allanNB 2012-03-28 15:59:58 UTC
issue persists in Netbeans 7.2 Beta (build 201203120400) and Parcellite 0.9.2


The lack of this feature costs me precious seconds every day. Please include it in 7.2 ! :)
Comment 8 Milutin Kristofic 2012-07-17 12:03:30 UTC
*** Bug 61083 has been marked as a duplicate of this bug. ***
Comment 9 Milutin Kristofic 2012-07-17 12:54:07 UTC
*** Bug 204223 has been marked as a duplicate of this bug. ***
Comment 10 Milutin Kristofic 2012-07-17 12:55:10 UTC
*** Bug 196829 has been marked as a duplicate of this bug. ***
Comment 11 Milutin Kristofic 2012-07-17 13:07:15 UTC
There are two reasonable plugins:
Dialog-one http://plugins.netbeans.org/plugin/31336/history-clipboard

and 
code completion-one http://plugins.netbeans.org/plugin/33351/copy-and-paste-history-for-netbeans-7-0-and-later
Comment 12 Mr_and_Mrs_D 2012-07-18 20:45:16 UTC
Just to note that the problem is that different programs that manipulate the clipboard fail with NB - not that NB should provide such functionality
Comment 13 Milutin Kristofic 2012-08-21 15:30:53 UTC
http://hg.netbeans.org/jet-main/rev/c3423559f4df

Shortcut is for now ctrl+alt+v. 

Mr_and_Mrs_D@netbeans.org:  http://www.lw-works.com/ page is broken and Parcellite has latest version from last year. I would file a bug in their report system.
Comment 14 Michel Graciano 2012-08-28 20:02:25 UTC
v. Build 20120828-074acc2249ea
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo