Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 56114

Summary: Change Method Return Type refactoring
Product: editor Reporter: Martin Matula <mmatula>
Component: RefactoringAssignee: Ralph Ruijs <ralphbenjamin>
Status: RESOLVED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: clever
Version: 4.x   
Target Milestone: 7.1   
Hardware: All   
OS: All   
Whiteboard:
Issue Type: ENHANCEMENT Exception Report:
Bug Depends on: 200232    
Bug Blocks: 65780    

Description Martin Matula 2005-03-10 08:52:27 UTC
It would be useful to add a Change Method Return Type refactoring (or extend
Change Method Parameters refactoring to allow changing return type).

Vince Kraemer wrote (on nbusers):

I think it would be nice to have a 'Change return type' refactor on methods.

It isn't very useful for standard java projects.
It can be pretty important for J2ee projects, though. An example would be
changing the return type of an "business method" on a enterprise javabean.

Creating the business method only makes one visible change in the project.

The user needs to do a couple changes to complete the return type change.

The second change (in the interface file) won't be obviously required until the
user gets a compilation error.
Comment 1 Ralph Ruijs 2011-06-03 13:02:39 UTC
*** Bug 66414 has been marked as a duplicate of this bug. ***
Comment 2 Ralph Ruijs 2011-07-22 07:10:19 UTC
Changeset: 32af1d7eec00
Author:    Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
Date:      2011-07-22 08:58
Message:   
Issue #56114 - Change Method Return Type refactoring
Comment 3 Quality Engineering 2011-07-25 14:09:09 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/32af1d7eec00
User: Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
Log: Issue #56114 - Change Method Return Type refactoring
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo