Bug 52012

Summary: Install problem nb4_0-rc1 under Turkish locale
Product: installer Reporter: bagcilar <bagcilar>
Component: CodeAssignee: mslama <mslama>
Status: RESOLVED WONTFIX QA Contact: issues <issues.netbeans.org>
Priority: P3 CC: anebuzelsky, blaha, mbalin, pkeegan, tmulligan
Version: 4.xKeywords: RELNOTE
Target Milestone: 4.x   
Hardware: PC   
OS: Windows XP   
Whiteboard:
Issue Type: DEFECT Exception Report:

Description bagcilar 2004-12-02 13:14:53 UTC
When execute netbeans-4_0-rc1-windows.exe these 
error occurs and installation canceled in Turkish 
Locale:
An unhandled error occured -- specify system 
property "is.debug" for more informatin.

When we change locale to English US there is no 
problem.

OS -> Win XP Turkish SP2
JDK -> J2SE 1.5.0
Locale Turkish
Comment 1 mslama 2004-12-02 13:20:02 UTC
Does installer cancel before anything is displayed? I will try to set
Turkish locale on English Win XP and reproduce it. We do not have
machine with Turkish Win XP. As workaround you can use zip distribution.
Comment 2 mslama 2004-12-09 11:52:52 UTC
*** Issue 52246 has been marked as a duplicate of this issue. ***
Comment 3 mslama 2004-12-17 12:58:56 UTC
I reproduced this issue. It looks like InstallShield problem -
exception is thrown from IS code. I will file bug to IS. Unfortunately
it happens  also with IS X SP2. I will test simplle test case too.

Patrick should we add note to Release Notes? (Add RENOTE keyword.) It
applies to all our installers.
Comment 4 Patrick Keegan 2004-12-17 16:57:49 UTC
For this release we're only release noting critical P2s, but this
might be something that we could add to the installation instructions
in a troubleshooting section.

Marek, does it happen in locales other than the Turkish locale? Is the
workaround to simply run the installer in a different locale, such as
English U.S.?

Talley, can you look into this?
Comment 5 Talley Mulligan 2004-12-17 17:49:29 UTC
so the installer simply quits before its finished when using any of
the localized versions of the netbeans 4.0/jdk 1.5 installer?

and is the problem limited to windows xp or does "all our installers"
mean on all platforms?

any ideas as to what we should suggest as a workaround?
Comment 6 mslama 2004-12-17 17:58:38 UTC
As said above. English installers have this problem (ie. non
localized) on Win XP with Turkish locale set. I do not know about
other locales - we have no other reports. But we did not test other
locales AFAIK. (I will CC QA.) It works fine with English U.S. locale
so workaround is to switch to English U.S. locale. As problem is in
InstallShield code I expect all our installers which are based on
InstallShield will have this problem but I did not test them all yet -
I tested and reproduced this problem with NetBeans installer.
Installer stops soon after start before it shows Welcome panel - it
shows just message box with error message as reported.  
Comment 7 mslama 2004-12-17 18:00:11 UTC
QA please could you add info on which locales do you test?
Comment 8 Ken Frank 2004-12-17 22:15:41 UTC
I used latest daily ml build and did not see the problem.
I am using en xp and regional settings (both basic and adv)
set to Turkish and I rebooted.

Could you retry with latest bits and see if issue ?

ken.frank@sun.com
Comment 9 Petr Blaha 2004-12-20 08:51:09 UTC
Thanks, Ken. 
We don't have resources to cover testing with various locales. Prague
QA team tests only with English locale.
Comment 10 mslama 2004-12-20 08:56:40 UTC
I must repeat it happens with English build of NetBeans on Win XP with
Turkish locale.

From reporter:
Change your XP's regional settings like this..

Regional Options->Standarts and formats-> Turkish, Location->Turkey
Advanced-> Language for non unicode programs->Turkish

I think the most important is to set "Language for non unicode programs".
Comment 11 mslama 2004-12-20 09:10:18 UTC
It is known InstallShield problem. It is not yet fixed. More info can
be found at
http://support.installshield.com/kb/view.asp?articleid=Q110959. The
only known workaround is to change system locale to other locale eg.
English U.S. Problem is reported only for Turkish locale.
Comment 12 mslama 2005-08-15 12:43:59 UTC
*** Issue 62246 has been marked as a duplicate of this issue. ***
Comment 13 Marek Grummich 2005-09-21 09:56:44 UTC
*** Issue 64574 has been marked as a duplicate of this issue. ***
Comment 14 mslama 2005-10-17 08:02:07 UTC
*** Issue 66917 has been marked as a duplicate of this issue. ***
Comment 15 mslama 2005-11-28 16:22:55 UTC
*** Issue 67802 has been marked as a duplicate of this issue. ***
Comment 16 Petr Blaha 2005-12-19 08:27:50 UTC
*** Issue 70550 has been marked as a duplicate of this issue. ***
Comment 17 Milan Kubec 2006-01-13 12:41:44 UTC
*** Issue 71252 has been marked as a duplicate of this issue. ***
Comment 18 mslama 2006-01-23 14:07:57 UTC
*** Issue 71376 has been marked as a duplicate of this issue. ***
Comment 19 mslama 2006-02-17 09:09:22 UTC
*** Issue 72759 has been marked as a duplicate of this issue. ***
Comment 20 mdakin 2006-06-04 18:10:43 UTC
It is amazing to see that this important (at least for all Turkish Java
developers) hasnt been solved and WONTFIX'ed easily sayin "This is an
InstallShield" bug.  Issue reported almost 2 years ago, and *nothing* happened.

- InstallShield says this is a HSQLDB bug, but that issue has been resolved in
HSQLDB almost a year ago
- Why are you using a proprietary installer which doesnt care about your bugs?
even if its a simple one?
- All Turkish java developers uses either Eclipse or soething other than
Netbeans, Guess why? Whwn I tell them "Hey, Netbeans has this cool matisse
thingy in new version" thay say, "Does it install without changing locale to
English"? .... 
- This bug also affects Azeri, Turkmen and some other locales too. 

I hope someone cares about this. 
Comment 21 mslama 2007-01-26 12:28:44 UTC
*** Issue 92579 has been marked as a duplicate of this issue. ***
Comment 22 mslama 2007-08-01 12:26:54 UTC
*** Issue 111224 has been marked as a duplicate of this issue. ***
Comment 23 Antonin Nebuzelsky 2007-08-01 12:51:52 UTC
FYI: with NetBeans 6.0 the problem is fixed.
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo