Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!

Bug 44856

Summary: Debugger views do not get focus
Product: platform Reporter: _ lcincura <lcincura>
Component: Outline&TreeTableAssignee: Stanislav Aubrecht <saubrecht>
Status: CLOSED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P3 Keywords: A11Y
Version: 4.x   
Target Milestone: 4.x   
Hardware: PC   
OS: Windows XP   
Whiteboard:
Issue Type: DEFECT Exception Report:
Bug Depends on: 33281    
Bug Blocks:    

Description _ lcincura 2004-06-15 10:17:49 UTC
NetBeans IDE 200406131800 on java 1.4.2_04

When some debugger view is opened via keyboard
shortcut, it does not get focus, so further
navigation via keyboard is not possible.
Comment 1 Jan Jancura 2004-06-17 09:24:11 UTC
Should be fixed...
Comment 2 _ lcincura 2004-06-22 08:19:24 UTC
According to
http://qa.netbeans.org/processes/a11y_bug_priority_guidelines.html
rising priority to P1
Comment 3 Jan Jancura 2004-06-25 10:49:48 UTC
I have fixed this issue on my side.
The problem is now in TreeTableView. It does not move focus on embeded
TreeView, I think. Focus work if I use BeanTreeView in place of
TreeTableView.


Checking in src/org/netbeans/modules/debugger/ui/views/CallStackView.java;
/cvs/debuggercore/src/org/netbeans/modules/debugger/ui/views/CallStackView.java,v
 <--  CallStackView.java
new revision: 1.4; previous revision: 1.3
done
Checking in src/org/netbeans/modules/debugger/ui/views/LocalsView.java;
/cvs/debuggercore/src/org/netbeans/modules/debugger/ui/views/LocalsView.java,v
 <--  LocalsView.java
new revision: 1.4; previous revision: 1.3
done
Checking in src/org/netbeans/modules/debugger/ui/views/ThreadsView.java;
/cvs/debuggercore/src/org/netbeans/modules/debugger/ui/views/ThreadsView.java,v
 <--  ThreadsView.java
new revision: 1.4; previous revision: 1.3
done
Checking in src/org/netbeans/modules/debugger/ui/views/WatchesView.java;
/cvs/debuggercore/src/org/netbeans/modules/debugger/ui/views/WatchesView.java,v
 <--  WatchesView.java
new revision: 1.4; previous revision: 1.3
done
Processing log script arguments...
More commits to come...
Checking in viewmodel/src/org/netbeans/modules/viewmodel/TreeTable.java;
/cvs/debuggercore/viewmodel/src/org/netbeans/modules/viewmodel/TreeTable.java,v
 <--  TreeTable.java
new revision: 1.7; previous revision: 1.6
done
Checking in
ui/src/org/netbeans/modules/debugger/jpda/ui/views/ClassesView.java;
/cvs/debuggerjpda/ui/src/org/netbeans/modules/debugger/jpda/ui/views/ClassesView.java,v
 <--  ClassesView.java
new revision: 1.3; previous revision: 1.2
done
Checking in
ui/src/org/netbeans/modules/debugger/jpda/ui/views/SourcesView.java;
/cvs/debuggerjpda/ui/src/org/netbeans/modules/debugger/jpda/ui/views/SourcesView.java,v
 <--  SourcesView.java
new revision: 1.3; previous revision: 1.2
done
Comment 4 Jan Chalupa 2004-06-28 09:26:23 UTC
P1->P2. A serious accessibility issue that should be fixed for the
release, but not necessarily immediately.
Comment 5 _ tboudreau 2004-07-20 19:27:57 UTC
> The problem is now in TreeTableView. It does not move focus on embeded
> TreeView, I think.

Hans, as far as I can tell, this is now working fine for debugger views.   TTV.requestFocus() 
is already written to send focus to the embedded TreeTable (the embedded TreeView is a 
cell renderer, never really on screen - so it should never actually have focus [but the tricks 
to make it think it does are part of the evil of the current implementation]).  I can't think 
what else it should do.

Therefore, I'm changing this to P3, future - it will be fixed with the TTV rewrite.
Comment 6 _ tboudreau 2004-07-29 02:56:02 UTC
There was a problem with focus not going to an inline editor when it was fixed, which I 
fixed tonight.  Not sure if this issue should remain open.
Comment 7 _ tboudreau 2004-08-17 13:06:58 UTC
AFAIK this bug is fixed; further improvements in focus behavior will 
come from the TTV rewrite.
Comment 8 Stanislav Aubrecht 2005-01-12 16:06:56 UTC
fixed 

Checking in src/org/openide/explorer/view/TreeTableView.java;
/cvs/openide/src/org/openide/explorer/view/TreeTableView.java,v  <-- 
TreeTableView.java
new revision: 1.70; previous revision: 1.69
done
Comment 9 _ lcincura 2005-07-12 16:15:32 UTC
Verified in 4.2 build 200507061800
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo