Bug 34762

Summary: postgreSQL driver no support to DatabaseMetadata
Product: db Reporter: massimo <massimo>
Component: CodeAssignee: issues <issues.netbeans.org>
Status: CLOSED DUPLICATE QA Contact: issues <issues.netbeans.org>
Priority: P1 CC:
Version: 3.x   
Target Milestone: TBD   
Hardware: PC   
OS: Windows ME/2000   
URL: http://jdbc.postgresql.org
Whiteboard:
Issue Type: DEFECT Exception Report:

Description massimo 2003-07-07 00:09:41 UTC
When testing postgreSQL driver 7.3 in NetBeans 3.5, you get 
an error message saying:
"Internal test driver incomplete. The driver may not 
support the required DatabaseMetadata methods. Take a look 
at the Output Window for details."
The OutputWindow shows:
---------------------
Testing driver org.postgresql.Driver.
Warning: No tables were found. Check your database.
Warning: No views were found. Check your database.
Warning: No procedures were found. Check your database.
---------------------
Looks like something's wrong with the driver, which might 
not implement correctly DatabaseMetadata.

PostgreSQL version used is 7.3.3
JDBC driver is pg73jdbc3.jar (JDBC3) downloaded from 
http://jdbc.postgresql.org/download.html

Other than that driver works just fine: you can connect to 
a postgreSQL database, you can query, insert, update and 
execute any SQL command. Everything works fine except that 
the Database Explorer does not seem to be able to get the 
metadata out of the database. It does not show any node 
under the "tables", "procedures" and "views" nodes, 
although it is connected just fine to a non empty database.

Could not find any work around to show the subnodes (for 
that i set priority 1, no workaround available).

Same thing happens when using the TDS driver for Microsoft 
SQL server, but i will wait on some feedback on this one 
before opening another issue on the that driver as well.
Comment 1 Radko Najman 2003-07-08 13:39:51 UTC
It seems like a duplicate of #31238.

*** This issue has been marked as a duplicate of 31238 ***
Comment 2 dmladek 2004-08-19 09:23:39 UTC
confirming as a dup
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo